Version 2.0.2 autocross posting even when disabled  


bdebruin
Posts: 25
Customer
(@bdebruin)
Member
Joined: 10 months ago

I am importing posts through a RSS feed and posts are saved in the category "Monday Post". This category is set to disabled from auto xposting in the "Auto Crossposting Setting". In version 2.0.1 posts in this category are indeed not xposted, however after installing 2.0.2 the posts in this excluded category are xposted automatically. I downgraded to 2.0.1 and the issue was solved, another upgrade to 2.0.2 made is appear again. This is clearly a 2.0.2 issue.

I makes no difference is the category is disabled or not mentioned in the "Auto Crossposting Setting". In both cases 2.0.1 works fine and 2.0.2 xposts regardless.

2019 09 29 20 46 41 Window

 

Topic Tags
11 Replies
Astghik
Posts: 3391
Admin
(@astghik)
Support Team
Joined: 2 years ago

Hi @bdebruin,

We've checked this on our test websites and don't find such issue. Are you sure the current post is not linked with another category as well? 

Reply
5 Replies
bdebruin
Customer
(@bdebruin)
Joined: 10 months ago

Member
Posts: 25

Hi @astghik

I doubled checked and the posts are not linked to another category. As stated, the "issue" went away after downgrading to 2.0.1. Upgrading again to 2.0.2 made it appear again.

 

Reply
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3391

ok @bdebruin,

Please click on the "Enable" button then "Disable" it and check again. 

 

Reply
bdebruin
Customer
(@bdebruin)
Joined: 10 months ago

Member
Posts: 25

hi @astghik

I upgraded again to 2.0.2. Then I enabled and disabled the category on the auto crossposting setting page. Still the same result. Then I removed the definition completely from the settings. Again same result (crossposting is activated). I downgraded again to 2.0.1 and issue is gone.

Reply
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3391

@bdebruin

please send the admin login details to info[at]gvectors.com emaila address. I'll ask developers to check the issue. 

Reply
bdebruin
Customer
(@bdebruin)
Joined: 10 months ago

Member
Posts: 25

@astghik

Done 

Reply
bdebruin
Posts: 25
Customer
(@bdebruin)
Member
Joined: 10 months ago

UPDATE

With 2.0.2. active I created 2 posts manually (not through RSS feed). Everything works as expected (one category xposted and the other not) based on the settings.

Only posts automatically created with a RSS feed gets always cross posted, even is the setting is disable for that category. This happens only in 2.0.2.

Reply
2 Replies
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3391

@bdebruin

Please install and activate the Duplicator — WordPress Migration Plugin, backup your WordPress site and send it to info[at]gvectors.com email address to allow us to check it. We cannot check it on the website. 

Reply
bdebruin
Customer
(@bdebruin)
Joined: 10 months ago

Member
Posts: 25

@astghik

Sorry for the late response. I noticed that there is an update of my RSS feed reader (WP RSS Aggregator) and I want to test somewhat further before bothering your team too much.

Keep you posted.

Reply
bdebruin
Posts: 25
Customer
(@bdebruin)
Member
Joined: 10 months ago

UPDATE

I did some further debugging and testing and found that the reason I experience different behavior between 2.0.1 and 2.0.2 is different than initially thought. 

I have disabled auto xposting based on the category which is set by my RSS reader and in 2.0.1. these posts are indeed not xposted. When I enabled this category for xposting in 2.0.1 I found that xposting did NOT occur at all. It looks like this is because of missing user rights and that this "issue" has been resolved in 2.0.2. So, the reason my RSS imported posts were not xposted in 2.0.1 is because of an issue later resolved in 2.0.2.

I also inserted some logging in the 2.0.2 version (right at the start of the function "transitionPostStatus") to inspect the post category. I found that every post from my RSS category hits this function four (!!) times and the first time the category is set to "Local post". It looks like this triggers the xposting as the category "Local post" is setup for auto xposting. The 2nd, 3rd and 4th time the same post has the category I disabled from auto xposting but at that time the forum topic is already created from the 1st time this function is called.

I also checked with creating posts manually and found out that if I created a post manually in a category that is enabled for xposting the xposting did occur (as expected). Changing the post category later on to a category that is disabled does not remove the forum topic. The other way around (start with the disabled category and change later to an enabled category) does create the forum topic at the time I change the category to an enabled category.

QUESTION: is it expected behavior that the forum topic is NOT removed when changing the category of the WP post to a category which is disabled for xposting.

In case this is expected behavior I need to created a workaound so that my RSS importer does not save the post with the category "Local post" before changing it to the category I disabled from xposting.

Many thanks for looking into this.

Reply
Astghik
Posts: 3391
Admin
(@astghik)
Support Team
Joined: 2 years ago
Posted by: @bdebruin

QUESTION: is it expected behavior that the forum topic is NOT removed when changing the category of the WP post to a category which is disabled for xposting.

yes this is designed to work in this way. I'm really sorry, but in this case, the forum topic is NOT removed when changing the category of the WP post. 

In case this is expected behavior I need to created a workaound so that my RSS importer does not save the post with the category "Local post" before changing it to the category I disabled from xposting.

Yes, the fix should be made from the RSS importer side. The wpForo Blog Cross Posting add-on works fine and nothing can be changed in the addon's codes. 

Reply
Share:
Green
Default
Pear
Black Emo
{green}:grinning:
{green}:wink:
{green}:face:
{green}:inlove:
{green}:sweaty:
{green}:surprised:
{green}:lovekiss:
{green}:laugh:
{green}:formalsmile:
{green}:displeased:
{green}:cool:
{green}:resent:
{green}:nerd:
{green}:screaming:
{green}:amazed:
{green}:sad:
{green}:deceitful:
{green}:starryeyes:
{green}:evil:
{green}:shocked:
{green}:tears:
{green}:sulky:
{green}:smile:
{green}:vomited:
{green}:hi:
{green}:afraid:
{green}:crazy:
{green}:rabid:
{green}:fighting:
{green}:nonoise:
{green}:blushed:
{green}:idontknow:
{green}:scared:
{green}:razz:
{green}:kiss:
{green}:eat:
{green}:shutmouth:
{green}:gape:
{green}:suspicious:
{green}:laughingoutloud:
{green}:bruise:
{green}:crying:
{green}:pray:
{green}:serious:
{green}:excitement:
:)
:d
:wink:
:mrgreen:
:neutral:
:twisted:
:arrow:
:shock:
:???:
:cool:
:evil:
:oops:
:razz:
:roll:
:cry:
:eek:
:lol:
:mad:
:sad:
:!:
:?:
:idea:
:hmm:
:beg:
:whew:
:chuckle:
:silly:
:envy:
:shutmouth:
{pear}:happy:
{pear}:smile:
{pear}:laugh:
{pear}:laughingoutloud:
{pear}:crying:
{pear}:exhausted:
{pear}:nerd:
{pear}:surprised:
{pear}:veryhungry:
{pear}:wink:
{blackemo}:laughtertotears:
{blackemo}:gift:
{blackemo}:love:
{blackemo}:inlove:
{blackemo}:shamefaced:
{blackemo}:heart:
{blackemo}:crazy:
{blackemo}:anguished:
{blackemo}:bruise:
{blackemo}:easymoney:
{blackemo}:exhausted:
{blackemo}:vampire:
{blackemo}:shutmouth:
{blackemo}:wink:
{blackemo}:carnival:
{blackemo}:flowers:
{blackemo}:hotdrink:
{blackemo}:party: