Image upload only works once in a while  

  RSS

knoxbronson
(@knoxbronson)
Member Customer
Joined: 3 weeks ago
Posts: 2
24/12/2018 4:01 am  

Hi-

I bought your Advanced Attachment plug-in and it only works once in a while.

Most of the time, I just get a broken image icon after upload. Or if the image icon shows up, and I hit "Add reply" in the forum, what I see in in the post is [attach]

I do not see the images that worked (or not) in my media library. Where do they go?

http://pixelsatanexhibition.com/community/main-forum/knox-testing-forum-for-pixels/#post-1

I am using Amazon S3 Bucket to host main site. From my developer: "Instead we’ve setup a rewriting mechanism that will proxy requests via your domain name to S3 bucket and fetch the images. Also we installed a free plugin “Offload site media” that will automatically upload new images to your S3 bucket."

Don't know if that's an issue.

Please help. I desperately need your lovely forums to work with easy image uploads!

-Knox

 


ReplyQuote
Topic Tags
Astghik
(@astghik)
Support Team Admin
Joined: 1 year ago
Posts: 1542
24/12/2018 5:27 pm  

Hi @knoxbronson,

Could you please navigate to Dashboard > Media Library and upload the same image (that has the problem) to your WP Media. Then get URLs and put in this post content and check how it works. 

 


ReplyQuote
knoxbronson
(@knoxbronson)
Member Customer
Joined: 3 weeks ago
Posts: 2
26/12/2018 12:01 am  

I plugged in the URL from the media library for this one. As I said, image upload works sometimes.

When I tried to upload this image directly to the forum, it showed the thumbnail of the image. I hit "upload" and it uploaded. When it was done, the icon changed to a broken image icon.

 

This post was modified 3 weeks ago by knoxbronson

ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2895
26/12/2018 5:17 pm  

This is something that cannot be controlled by wpForo Advanced Attachments addon. As far as I see the Amazons S3 could system copies the same image on different servers with different URLs. It works like CDN system and does this to load images from other servers. If an uploaded fie is large or if during the uploading process it's busy the files are not being copied yet and the image become unavailable.

I'm really sorry but we only see two solution here:

1. Disable file storage in S3 could system

2. Or we have to refund this addon, because we cannot fix it from the addon side.


ReplyQuote
Share: