Social login icons and wordpress login  

  RSS

paulgc
(@paulgc)
Active Member
Joined: 3 weeks ago
Posts: 6
03/01/2020 10:34 pm  

Hello,

Is it possible to disable the Wordpress login and only have the Social login available to users? Also, would like to have the Social logins on the left hand side of the form.

Thank you for your assistance.

Regards,

Paul


Quote
Elvina
(@elvina)
Reputable Member Moderator
Joined: 5 months ago
Posts: 425
08/01/2020 12:25 pm  
Posted by: @paulgc

is it possible to disable the Wordpress login and only have the Social login available to users?

1.  If you mean the text above the comment form, you can simply hide it. You just navigate to Dashboard > Comments > Settings >Comment Form admin page and enable the "Hide "Please login to comment" text" option. More info here: https://wpdiscuz.com/docs/wpdiscuz-documentation/settings/comment-form/#components

2.  Otherwise, if you want to disable the Wordpress login you need to use some other plugin for this purpose.  The feature doesn't have any relation to the wpDiscuz. We've found the plugins that may help you. Please check out those:

https://wordpress.org/plugins/disable-login/

https://wordpress.org/plugins/wp-users-disable/

I'm sorry but this is designed to work in this way.

Posted by: @paulgc

Also, would like to have the Social logins on the left hand side of the form.

Please navigate to Dashboard > Comments > Settings > Styling admin page, put the following CSS code in the "Custom CSS code" textarea: 

#wpcomm .wpdiscuz-form-top-bar .wpdiscuz-ftb-right{
float: left;
}

Don't forget to delete all caches and press CTRL+F5(twice) on the front end before checking. 


ReplyQuote
paulgc
(@paulgc)
Active Member
Joined: 3 weeks ago
Posts: 6
09/01/2020 7:46 pm  

Hi Elvina,

Thank you for the response. I tried using the custom CSS you sent but the social logins are still showing on the right hand side, even after clearing all caches.

Also, i am having a hard time trying to hide the login URL from the Comments form, none of those plugins mentioned, worked as the link still shows up in the page source.

Any other ideas for this please?

Regards,

Paul


ReplyQuote
Elvina
(@elvina)
Reputable Member Moderator
Joined: 5 months ago
Posts: 425
10/01/2020 11:15 am  

@paulgc,

Thank you for the response. I tried using the custom CSS you sent but the social logins are still showing on the right hand side, even after clearing all caches.

Please delete the old code and try the  following one:

#wpcomm .wpdiscuz-form-top-bar .wpdiscuz-ftb-right{
float: left !important;
}

If the issue still exists, please leave the example URL to allow us to check it.

Please don't forget to delete all caches and press CTRL+F5(twice) on the front end before checking. 

1.  If you mean the text above the comment form, you can simply hide it. You just navigate to Dashboard > Comments > Settings >Comment Form admin page and enable the "Hide "Please login to comment" text" option. More info here: https://wpdiscuz.com/docs/wpdiscuz-documentation/settings/comment-form/#components

Have you tried this solution? If you enable the option it should hide the login URL.

Posted by: @paulgc

Also, i am having a hard time trying to hide the login URL from the Comments form, none of those plugins mentioned, worked as the link still shows up in the page source.

Any other ideas for this please?

I'm sorry but this is not the wpDiscuz feature, as I already mention you need to use some other plugin for this.


ReplyQuote
paulgc
(@paulgc)
Active Member
Joined: 3 weeks ago
Posts: 6
10/01/2020 5:59 pm  

@elvina

Hi Elvina,

Thank you for the quick response. I used the new code you sent and its working great! FYI i had to put it in the Form's CSS to make it work.

The "Hide "Please login to comment" text" option only worked after i enabled guest commenting. Is there a way to hide the "please login to comment" without enabling guest commenting?

Also, is there a way to show "Logged in as ......" without the logout link?

Regards,

Paul


ReplyQuote
Elvina
(@elvina)
Reputable Member Moderator
Joined: 5 months ago
Posts: 425
11/01/2020 11:50 am  
Posted by: @paulgc

The "Hide "Please login to comment" text" option only worked after i enabled guest commenting. Is there a way to hide the "please login to comment" without enabling guest commenting?

You can use the following CSS code:

#wpcomm .wpdiscuz-form-top-bar #wc_show_hide_loggedin_username{
display:none;
}
Posted by: @paulgc

Also, is there a way to show "Logged in as ......" without the logout link?

Please use this code:

#wpcomm #wc_show_hide_loggedin_username > a:last-child {
display: none !important;
}

All CSS codes should be added in Dashboard > Comments > Settings > Styling admin page in the "Custom CSS code" textarea.

In any case, please don't forget to delete all caches and press Ctrl+F5 (twice) on the frontend before.


ReplyQuote
paulgc
(@paulgc)
Active Member
Joined: 3 weeks ago
Posts: 6
13/01/2020 1:35 pm  

@elvina

Hellow Elvina,

Thank you for the response.

The CSS code you gave worked well, however, i would like to hide "Logout" text (with the code you gave) but how can i keep the login URL secret so that it does not show up in the page source, if this is possible?

Regards,

Paul


ReplyQuote
Elvina
(@elvina)
Reputable Member Moderator
Joined: 5 months ago
Posts: 425
13/01/2020 3:11 pm  

@paulgc,

Please add the following js codes in your active theme js files and check again. The code provided below should solve the issue:

jQuery( "#wpcomm #wc_show_hide_loggedin_username > a:last-child " ).removeAttr("href");

 


ReplyQuote
paulgc
(@paulgc)
Active Member
Joined: 3 weeks ago
Posts: 6
13/01/2020 5:40 pm  

@elvina

Hi Elvina,

Thank you. I am not too familiar with adding js code but i will see if i can figure it out somehow without breaking anything. Sweaty  

Regards,

Paul

 


ReplyQuote
Elvina
(@elvina)
Reputable Member Moderator
Joined: 5 months ago
Posts: 425
14/01/2020 10:43 am  

@paulgc,

Here is the instruction on how to add a js file or js code in the active theme:

https://www.wpbeginner.com/wp-tutorials/how-to-easily-add-javascript-in-wordpress-pages-or-posts/


ReplyQuote
paulgc
(@paulgc)
Active Member
Joined: 3 weeks ago
Posts: 6
16/01/2020 8:01 pm  

Hi Elvina,

Thank you for the information, i will read the article and try your suggestion.

Regards,

Paul


ReplyQuote
Share:
Green
Default
Pear
Black Emo
{green}:grinning:
{green}:wink:
{green}:face:
{green}:inlove:
{green}:sweaty:
{green}:surprised:
{green}:lovekiss:
{green}:laugh:
{green}:formalsmile:
{green}:displeased:
{green}:cool:
{green}:resent:
{green}:nerd:
{green}:screaming:
{green}:amazed:
{green}:sad:
{green}:deceitful:
{green}:starryeyes:
{green}:evil:
{green}:shocked:
{green}:tears:
{green}:sulky:
{green}:smile:
{green}:vomited:
{green}:hi:
{green}:afraid:
{green}:crazy:
{green}:rabid:
{green}:fighting:
{green}:nonoise:
{green}:blushed:
{green}:idontknow:
{green}:scared:
{green}:razz:
{green}:kiss:
{green}:eat:
{green}:shutmouth:
{green}:gape:
{green}:suspicious:
{green}:laughingoutloud:
{green}:bruise:
{green}:crying:
{green}:pray:
{green}:serious:
{green}:excitement:
:)
:d
:wink:
:mrgreen:
:neutral:
:twisted:
:arrow:
:shock:
:???:
:cool:
:evil:
:oops:
:razz:
:roll:
:cry:
:eek:
:lol:
:mad:
:sad:
:!:
:?:
:idea:
:hmm:
:beg:
:whew:
:chuckle:
:silly:
:envy:
:shutmouth:
{pear}:happy:
{pear}:smile:
{pear}:laugh:
{pear}:laughingoutloud:
{pear}:crying:
{pear}:exhausted:
{pear}:nerd:
{pear}:surprised:
{pear}:veryhungry:
{pear}:wink:
{blackemo}:laughtertotears:
{blackemo}:gift:
{blackemo}:love:
{blackemo}:inlove:
{blackemo}:shamefaced:
{blackemo}:heart:
{blackemo}:crazy:
{blackemo}:anguished:
{blackemo}:bruise:
{blackemo}:easymoney:
{blackemo}:exhausted:
{blackemo}:vampire:
{blackemo}:shutmouth:
{blackemo}:wink:
{blackemo}:carnival:
{blackemo}:flowers:
{blackemo}:hotdrink:
{blackemo}:party: