No Membership Pleas...
 
Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum   wpForo Support Forum

[Solved] No Membership Please  

  RSS

Joshie
(@joshie)
Member Customer
Joined: 4 months ago
Posts: 8
24/03/2020 5:25 am  

I don't know how exactly to go about this before I go ahead and start off I want to say that I have purchased the bundle add-ons for wpDiscuz which I have used for many years but with no add-ons so it's been fantastic to me to the point that I felt that it was time to add more features to the comments system.

Now I am in need of some helps (2), I have pretty much uploaded all of the plugins except the media, advertise, private comment and I am sure one or two more I am missing. I was excited but as soon I have activated everything and noticed that everything was going smooth... That is until I realize that anyone who uses the social logins such as Facebook or Twitter to leave a comment practically automatically register themselves which is a big no-no to me because I don't want anyone to have a registered account within' the wordpress. When they used social media logins such as Facebook/Twitter, they automatically registered (as a contributor) and be able to access the WordPress dashboard - again a big no no. Now, how do I prevent anyone from registering an account within' wordpress? I don't want to see anyone to automatically register to my wordpress website using the wpDiscuz. I have disabled the facebook and twitter login/share to stop this for the time being so I can seek some help by stopping anyone from registering an account within' wordpress. I was hoping that people can log in to leave a comment using their social login without automatically registering to the wordpress. My wordpress has set to not accept any register.

Second help - how do I remove the post part/icon from the commenter's author info? Because I don't allow anyone to write post/articles other than myself and some of my co-workers on occasional so it's weird seeing it there when they don't write blog posts/articles.

 

Thanks so much, for any help!!

This topic was modified 4 months ago by Joshie

Quote
Astghik
(@astghik)
Support Team Admin
Joined: 3 years ago
Posts: 4208
24/03/2020 12:36 pm  

Hi @joshie,

When they used social media logins such as Facebook/Twitter, they automatically registered (as a contributor) and be able to access the WordPress dashboard - again a big no no. Now, how do I prevent anyone from registering an account within' wordpress? 

We'll discuss it with our team and let you know asap. Currently, there is no way to post a comment without user registration via the social login feature. 

Second help - how do I remove the post part/icon from the commenter's author info? Because I don't allow anyone to write post/articles other than myself and some of my co-workers on occasional so it's weird seeing it there when they don't write blog posts/articles.

All the settings are located in the Dashboard > Comments > Settings > Addons > Comment Author Info tab. If you don't find the option to hide the info, please provide us some screenshot that you need to hide, we'll provide a CSS solution for you. 


ReplyQuote
Joshie
(@joshie)
Member Customer
Joined: 4 months ago
Posts: 8
25/03/2020 5:20 am  

@astghik Here's a screenshot of my setting, I don't see the option.

Annotation 2020 03 24 211806

I have circled the part that I don't want to show.

Annotation 2020 03 23 201719 LI

Thanks!

 


ReplyQuote
Astghik
(@astghik)
Support Team Admin
Joined: 3 years ago
Posts: 4208
25/03/2020 11:43 am  

@joshie,

Use the following CSS code:

.wcai-profile-stat-box:nth-child(2) {
display: none !important;
}

Put the code in the "Custom CSS Code" textarea, located in the Dashboard > Comments > Settings > styling admin page. 

Don't forget to delete all caches and press CTRL+F5(twice) on the frontend before checking. 

We'll discuss it with our team and let you know asap. Currently, there is no way to post a comment without user registration via the social login feature. 

We've added in our to-do list and will implement the feature in future updates. 

 


Joshie liked
ReplyQuote
Joshie
(@joshie)
Member Customer
Joined: 4 months ago
Posts: 8
26/03/2020 11:27 am  
Posted by: @astghik

@joshie,

Use the following CSS code:

.wcai-profile-stat-box:nth-child(2) {
display: none !important;
}

Put the code in the "Custom CSS Code" textarea, located in the Dashboard > Comments > Settings > styling admin page. 

Don't forget to delete all caches and press CTRL+F5(twice) on the frontend before checking. 

We'll discuss it with our team and let you know asap. Currently, there is no way to post a comment without user registration via the social login feature. 

We've added in our to-do list and will implement the feature in future updates. 

 

That works, although it looks a bit weird as having a white space with nothing there but it's better than having there though. Thanks!

Also, please fix the social media log-ins that does not automatically register an account within' Wordpress whenever possible. Again, thank so much!


ReplyQuote
Astghik
(@astghik)
Support Team Admin
Joined: 3 years ago
Posts: 4208
26/03/2020 2:18 pm  

@joshie,

That works, although it looks a bit weird as having a white space with nothing there but it's better than having there though. Thanks!

Then I'd suggest you use this CSS code as well. It should be solve the issue. 

.wcai-wrapper .wcai-profile-stat-box {
width: 32%;
}

 


ReplyQuote
Joshie
(@joshie)
Member Customer
Joined: 4 months ago
Posts: 8
01/04/2020 6:31 am  

Consider this solved. Thanks!


ReplyQuote
Joshie
(@joshie)
Member Customer
Joined: 4 months ago
Posts: 8
27/05/2020 2:05 pm  

I am bringing this back since the huge upgrade, which I am overly impressed with WPDiscuz. Still, there is a question that lingers - did you make it to where those commentators won't automatically register within' Wordpress system? Because I have seen others that don't automatically register a Wordpress account when you use the social login feature, but this one does. I do wish that I have the option where they can log in using their social accounts for their names/avatars but not register an account with Wordpress.

Thanks!


ReplyQuote
Share: