Shortcode use only
 

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum   wpForo Support Forum

Shortcode use only  

  RSS

atooby
(@atooby)
Active Member
Joined: 2 months ago
Posts: 9
28/03/2020 10:45 pm  

Hi there, I would like to ONLY use the shortcode option to display my comments.

Is it possible to turn off the auto display comments on post option, but allow the shortcode to display on that page?

The reason why I want to do this is because with wordpress you cannot add your own blog footer. I have designed one with my page builder and would like to insert the comments shortcode above it. However by default, with wpdiscuz turned on for posts, the comments appear below the newly designed footer.

If I can hide them, but keep the shortcode my problem would be solved.

Thank you!


Quote
Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 4129
29/03/2020 4:16 pm  

Please try the steps below:

1. Navigate to Dashboard > Comments > Forms, edit the Default Form uncheck it for the current post type, save it then do Ctrl+F5 on front-end.

wpDiscuz custom post type settings

2. use the wpDiscuz shortcode. the shortcode can be found here: https://wordpress.org/support/topic/shortcode-for-wpdiscuz/


ReplyQuote
atooby
(@atooby)
Active Member
Joined: 2 months ago
Posts: 9
29/03/2020 7:16 pm  

I tried that but it just removes all formatting from the shortcode, and the original comments are replaced by my default theme comments it seems:

 

Shortcode display after unchecking 'posts' in form

Screen Shot 2020 03 29 at 8.12.19 AM

 

comments still displaying by theme after unchecking 'posts' in form.

Screen Shot 2020 03 29 at 8.12.26 AM

 

Thank you


ReplyQuote
Elvina
(@elvina)
Noble Member Moderator
Joined: 9 months ago
Posts: 1039
30/03/2020 4:03 pm  

@atooby,

Please follow the steps below:

1. Navigate to Dashboard > Comments > Forms, edit the Default Form enable it for the current post type, save it then do Ctrl+F5 on front-end.

2. Then contact to your active theme developers and ask them to delete the <?php comments_template() ?> function in the template files and check again.
 

 


ReplyQuote
atooby
(@atooby)
Active Member
Joined: 2 months ago
Posts: 9
31/03/2020 7:20 pm  

Thank you for your reply.

If I remove <?php comments_template() ?>, wpdiscuz comments still display in both areas (default & shortcode).

If I turn off the 'post' option in the form, the comments only display in the shortcode (as intended) but I lose all formatting and style.

Screen Shot 2020 03 29 at 8.12.19 AM

Not sure what I'm missing.

 

Thank you,


ReplyQuote
Elvina
(@elvina)
Noble Member Moderator
Joined: 9 months ago
Posts: 1039
01/04/2020 1:08 pm  

@atooby,

Please make sure you're deleted the <?php comments_template() ?> for post types, and check again.

 


ReplyQuote
atooby
(@atooby)
Active Member
Joined: 2 months ago
Posts: 9
01/04/2020 7:51 pm  

I have done that.

As you can see on this page: https://alextooby.com/how-to-get-more-views-on-youtube/

 

The area where the shortcode is is messed up, but no other comments appear.

It's just the styling I'm not sure how to keep.

 

thank you 


ReplyQuote
Elvina
(@elvina)
Noble Member Moderator
Joined: 9 months ago
Posts: 1039
02/04/2020 12:50 pm  

@atooby,

Please send the admin login details to info[at]gvectors.com email address. I'll ask the developers to check it for you. 

 


ReplyQuote
atooby
(@atooby)
Active Member
Joined: 2 months ago
Posts: 9
02/04/2020 4:05 pm  

I appreciate that. I've just sent them over.

 

Thank you!


ReplyQuote
Elvina
(@elvina)
Noble Member Moderator
Joined: 9 months ago
Posts: 1039
02/04/2020 5:31 pm  

@atooby,

For farther support please enabled theme editing feature, to allow our developers to check it.

 


ReplyQuote
atooby
(@atooby)
Active Member
Joined: 2 months ago
Posts: 9
03/04/2020 12:38 am  

@elvina I'm not sure what you mean?

I might need to whitelist your IP address to allow you to make edits. Please let me know what it is and I'll do that right away.

Thank you


ReplyQuote
Elvina
(@elvina)
Noble Member Moderator
Joined: 9 months ago
Posts: 1039

ReplyQuote
atooby
(@atooby)
Active Member
Joined: 2 months ago
Posts: 9
03/04/2020 6:38 pm  

Done. Thank you!


ReplyQuote
Elvina
(@elvina)
Noble Member Moderator
Joined: 9 months ago
Posts: 1039
04/04/2020 5:44 pm  

@atooby,

As far as we see the issue is already fixed.

 


ReplyQuote
atooby
(@atooby)
Active Member
Joined: 2 months ago
Posts: 9
05/04/2020 3:57 am  

No it is not fixed..

 

I turned comments back on while waiting for your reply.

If you view this blog: https://alextooby.com/how-to-get-more-views-on-youtube, you will see there is a instance of the wpdiscuz shortcode ([wpdiscuz_comments]), as well as the default generated comments.

If you turn off 'post' type in the wpdiscuz form, it loses all formatting (as discussed above). 

I can remove the <?php comments_template() ?> again, which will take away the default comments but the formatting of the shortcode comments is still lost.

Please let me know if this still isn't clear..

 

Would love to get this sorted soon!

Thanks,


ReplyQuote
Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 4129
06/04/2020 3:44 pm  

@atooby,

I can remove the <?php comments_template() ?> again, which will take away the default comments but the formatting of the shortcode comments is still lost.

Yes, you should remove it, then make sure the form enable it for the post type as mentioned here: 

Navigate to Dashboard > Comments > Forms, edit the Default Form enable it for the current post type, save it then do Ctrl+F5 on front-end.

If those two points will be done, delete all caches and check again. You should not be faced with the issue. 


ReplyQuote
Share: