When logged in, fields don’t show up  


I’m trying to use your plugin but when a user/customer is logged in, the name, email, and capcha input fields never expand so if someone selects “Post Question” they get the error that fields are missing. Is there anyway to fix this? If you are not logged in, there is no problem at all and the field expand as expected. 


i've been looking at this more. Looks like when you're logged in those fields aren't supposed to show up yet I keep getting the "Some of field value is invalid" notification so no one logged in can ever leave a question. I'll pay for help. 


This  error is doesn't come from WooDiscuz. If you're not logged-in you should not see other fields. Only Text field should be displayed, all is correct. 

I guess some other plugin tries to add something in WooDiscuz comment form and tries to validate it on comment submission. I'd recommend to disable all other plugins, test WooDiscuz and then activate those one by one to find the one which cause this issue. Make sure you've disabled cache before checking.

wpDiscuz Documentation

After more testing I see that the name and email fields aren't supposed to be shown when you're logged in. But then why would I get the error that a field value is incorrect? Why when submitting a wooDiscuz form would another plugin affect how wooDiscuz validates the form data? I'm looking for a direction of the type of plugin that could be causing an issue if that's really the issue. The site runs lots of plugins so simply disabling them all isn't the best plan of attack. 

You should deactivate all plugins related to comments, for example Comment Plugins, AntiSpam, CAPTCHA and security plugins. There is no way to debug your issue and help. This is something very specific and depends on set of plugins and themes.


can you tell me ways that error message can be triggered? 

Again it's the "Some of field value is invalid" notification shown. This assuming it's your plugin that determines when to display this message. 

Edited: 9 months  ago

Plugins adds hidden fields for antispam purposes or for other security purposes. WooDiscuz only submits WooDiscuz fields. These plugins check submitted data in new comment inserting hook, if they don't find their hidden field values they return error.


I've deactivated every plugin except woocommerce and WooDiscuz and the error still shows up. I've also cleared my functions.php file just to be sure there isn't anything in there that could be causing this either. I still get the error. I've set the theme to the stock storefront theme and still get the error. I've cleared server side cache, I still get the error. 

What else could it be? 

Please leave website URL, it seems you have a JS bug, we need to debug those to find the issue.


Here is the URL :  http://wrightwoodsurveillance.com/product/testing-product/

- when not logged in, works as expected
- when logged in, does not work


Hi, have you guys been able to take a look at this to see what might be going on here? 



Please Login or Register