Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum wpForo Support Forum

[Solved] Problems with the new update

7 Posts
4 Users
1 Likes
105 Views
Gustavo Melim
Posts: 5
Customer
Topic starter
(@gustavo-melim)
Member
Joined: 12 months ago

In this update 2.x my site broken, i have a lot of work to fix this but i have a problem, when i update wpforo and addons to new versions all foruns and posts of my plataform disapear, i fix this with downgrade to old versions of wpforo and addons, but the layouts dont work, i use the qa layout, but he change to extend layout, and the configurations of foruns cant save changes, i debug in localhost and receive this message: "Warning: Trying to access array offset on value of type null in C:\xampp\htdocs\testedb\wp-content\plugins\wpforo\wpf-includes\class-forums.php on line 809" in forum config page and this message: "Warning: Undefined array key "cat_layout" in C:\xampp\htdocs\testedb\wp-content\plugins\wpforo\wpf-includes\class-forums.php on line 505" on edit forum page, i see the code and the array with problem is the array with "cat_layout" value. Why changes in the database i have to made to fix this problem? I try a lot of changes and nothing work.

Topic Tags
6 Replies
Tom
Posts: 3858
 Tom
Admin
(@tomson)
Famed Member
Joined: 7 years ago

Please follow these steps:

  1. Deactivate all addons
  2. Deactivate and delete Go2wpForo plugin if you have instaled it
  3. If you have customized forum template files in the current active WordPress direcotry you should delete them, they are usually saved in /wp-content/themes/youractive-theme/wpforo/ folder
  4. Update wpForo to the latest version
  5. Activate wpForo
  6. Update addons to 3.0.x versions, use manually update method, delete current addons if they are not 3.0.x verions, download new ones from your account, here is the instruction: https://gvectors.com/forum/postid/33094/
Cindy.Tunstall@elotr.com
Posts: 12
(@cynthia-tunstall)
Member
Joined: 6 months ago

Will I lose any of the content that is currently posted if I delete and deactivate?

1 Reply
Kyle
 Kyle
Admin
(@kylew)
Joined: 1 year ago

Reputable Member
Posts: 337
Gustavo Melim
Posts: 5
Customer
Topic starter
(@gustavo-melim)
Member
Joined: 12 months ago

The new update dont show my old forum posts (this is a big problem), i try now the 2.0.4 upgrade and this is the same problem, i wanna to fix the changes in old version plugin. After restore old plugin the changes broke the add foruns function of plugin, i wanna to fix that, problaby is a database change in the update who cause that, i wanna know who change are made cause this problem to fix that in my plataform, i dont wanna update to new version, i need to fix this problem generated by this update to plugin works good like before this nightmare update.

Gustavo Melim
Posts: 5
Customer
Topic starter
(@gustavo-melim)
Member
Joined: 12 months ago

The problem is with the cat_layout variable with null value in the code, only i need is the way to fix that to restore wp-foro1.9.9.1 works good like before the update, losing the foruns posts data is not a option for me, i dont need update, only restore the old plugin

Page 1 / 2
Share:
Scroll to top