Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum wpForo Support Forum

Add attachment button not displayed on custom post type


Ben Drohan
Posts: 12
Customer
Topic starter
(@bendrohangmail-com)
Member
Joined: 4 years ago

Hello,

The add a file button disappeared after I updated wpDiscuz plugins. It was working before, but now I don't see it on custom post type.

I think it's related to some media settings, but I don't see anything that could be causing it. See attachment for media settings.

I checked the plugin files and I had to set isUploadingAllowed function to always return true to make the add a file button appear again. So it looks like some settings are blocking uploading on custom post types.

Can you take a look and let me know how can I fix it?

 

File path: \wp-content\plugins\wpdiscuz\utils\class.WpdiscuzHelperUpload.php

Function name: isUploadingAllowed

Plugin versions:

wpDiscuz - Version 7.2.2

wpDiscuz Media Uploader - Version 7.0.9

Screenshot 2021 07 31 at 12 12 16 » Settings — WordPress
3 Replies
Astghik
Posts: 5048
Admin
(@astgh)
Support Team
Joined: 4 years ago

Hi Ben Drohan,

We don't find such an issue on our test websites. Could you please send the admin login details to info[at]gvectors.com email address? I'll ask the developers to check the issue for you. 

Reply
Ben Drohan
Posts: 12
Customer
Topic starter
(@bendrohangmail-com)
Member
Joined: 4 years ago

Hello,

My developer sent you access details for both live and dev site (you can make changes on dev site to figure out the issue).

Reply
1 Reply
Astghik
Admin
(@astgh)
Joined: 4 years ago

Support Team
Posts: 5048

Thank you @bendrohangmail-com!

We've checked your website. Somehow, the users don't have any role on your website. Please ask your developer to check the issue and find why the user's don't have any roles on your website. 

Once this issue is solved, the addon will work fine. 

Reply
Share:
Scroll to top