404 Error when I try to clear Gravatar cache  

  RSS

byjillee
(@byjillee)
New Member
Joined:4 months  ago
Posts: 3
13/02/2018 11:58 pm  

Hi,

Some of the users who leave a comment are displaying the default gravatar image  https://d.pr/i/gyzcOE and I'm not sure why. I have a custom Gravatar set for commenters on my site, you can see it above and below the default gravatar icon in the image above.

I tried clearing my gravatar cache in the wpdiscuz settings but when I do I get a 404 error message.


ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined:3 years  ago
Posts: 2603
14/02/2018 12:24 am  

Please disable other plugins and check it. Also please disable wpDiscuz and check it. Make sure this is a wpDiscuz specific issue.

Also please navigate to Dashboard > Settings > Discussions admin page and check WordPress native avatar settings, leave a screenshot of the avatars options, I want to see which one is selected.

Also please try to disable wpDiscuz Avatar cache.

Edited: 3 months  ago

ReplyQuote
byjillee
(@byjillee)
New Member
Joined:4 months  ago
Posts: 3
14/02/2018 10:18 am  

Hi, I turned off gravatar caching and it seems to have fixed the problem. What is the downside to having gravatar caching turned off?


ReplyQuote
dej.sf
(@dej-sf)
New Member
Joined:2 months  ago
Posts: 1
21/03/2018 8:49 am  
Posted by: Tom

Please disable other plugins and check it. Also please disable wpDiscuz and check it. Make sure this is a wpDiscuz specific issue.

Also please navigate to Dashboard > Settings > Discussions admin page and check WordPress native avatar settings, leave a screenshot of the avatars options, I want to see which one is selected.

Also please try to disable wpDiscuz Avatar cache.

It seems that your URL request is wrong after version bumping to 5.

The correct URL for clearing the avatar cache should be: mysite/wp-admin/admin-post.php?action=purgeGravatarsCaches&_wpnonce=XXXX

The acutal URL is: mysite/wp-admin/admin-post.php?/action=purgeGravatarsCaches&_wpnonce=XXXX

Aware of the redundant slash character following "admin-post.php", resulting into a 404 error.

The same problem also occurs for your addon-disable function. Hope this get fixed.


ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined:3 years  ago
Posts: 2603
22/03/2018 1:21 pm  

Thank you dej.sf,

We see the issue, it'll be fixed in next version release.


ReplyQuote
Share: