Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum wpForo Support Forum

How to solely allow comments from registered forum users under the blog posts?


Tessa Geniets
Posts: 5
Customer
Topic starter
(@tessa-geniets)
Member
Joined: 7 months ago

Maybe I'm asking a stupid question here. I had some really bad experiences with spam on another website, so I disabled the option on my blog posts altogether (www.lifetolegend.com).

But to have interaction still, I installed the blog cross posting addon.
However, I don't know Wordpress that well yet (I came from Joomla) so, consider me a noob and do a step by step explanation please!

how do I enable my comments again, while only allowing registered forum members to reply?

Thank you!

4 Replies
Tom
Posts: 3719
 Tom
Admin
(@tomson)
Support Team
Joined: 6 years ago

Hi @tessa-geniets,

Please navigate in Dashboard to WordPress Settings > Discussions admin page and turn on  the following options. Then delete all caches if you have a cache plugin:

  • Allow people to submit comments on new posts
  • Users must be registered and logged in to comment
Reply
Tessa Geniets
Posts: 5
Customer
Topic starter
(@tessa-geniets)
Member
Joined: 7 months ago

Thank you Tom for explaining!

I run into one problem, I hope you can clarify for me.

So, turns out that the option to comment was always there. But because I removed the comment block (in Elementor, I kinda never added it) I never got any.
The registered users option is now enabled.

Anyhow, everything seems to work. When I'm logged out, it tells me to log in. A nice comment display appears and I can write something.
However, when I press on 'send' it says:

Sorry, comments are closed for this item.

I checked some of the articles where this happens (I haven't found any in which it does work properly) but I didn't disable comments on inidividual articles (that is, in the edit post sidebar).

Can you tell me what I'm doing wrong here?
Thank you!
~Tess

Reply
Tessa Geniets
Posts: 5
Customer
Topic starter
(@tessa-geniets)
Member
Joined: 7 months ago

Ps, I did clear my browser cache. I don't think I had any cache enabled on my wordpress site, but in that sense, it's all still a bit confusing to me. Is it connected to jetpack or something? As I could only find one I installed myself (WP-Optimize) which I never enabled.

Reply
Tom
Posts: 3719
 Tom
Admin
(@tomson)
Support Team
Joined: 6 years ago

@tessa-geniets,

Please edit the post/page and find "Allow discussion" option. You should enable it. Here is the full list of steps you should check to enable the comment section: https://wpdiscuz.com/docs/wpdiscuz-7/getting-started/missing-comment-form/

Reply
Share:
Scroll to top