Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum   wpForo Support Forum

Widget tabs do not work  


cheryldimof
Posts: 19
Customer
(@cheryldimof)
Member
Joined: 1 year ago

Hi, 

I just installed the widgets addon, but switching between tabs when multiple tabs are enabled does not work. I use the Divi theme. I saw a similar post here from a couple of years back, that Divi's js interefered with that of the plugin, but no solution was noted.

FYI, I've tried disabling the "Use theme's widget title structure" option.

Was there a solution for this issue?

8 Replies
cheryldimof
Posts: 19
Customer
(@cheryldimof)
Member
Joined: 1 year ago

Additionally, I'm finding that Gravatars are showing for "Most Voted Comments" and "Active Commenters" tab, but not for "Active Comment Threads" (perhaps an icon is supposed to show here, but on this widget it shows a white box on the circle background), "Active Commenters" is showing a default Monster ID gravatar for a user whose actual gravatar displays fine on "Active Commenters."

Thanks

Cheryl

Reply
1 Reply
Elvina
Moderator
(@elvina)
Joined: 11 months ago

Noble Member
Posts: 1215

@cheryldimof,

Please leave the example URL to allow us to check it.

 

Reply
cheryldimof
Posts: 19
Customer
(@cheryldimof)
Member
Joined: 1 year ago

Hi, 

OK, I put a widget with all of the tabs on this page:

https://www.pnwbeyond.com/travel-blog-travel-tips-travel-destinations/

The other issue here was that the same default avatar is showing even for guest users who have their own avatar showing in comments:

widget

Thanks, 

Cheryl

Reply
1 Reply
Astghik
Admin
(@astghik)
Joined: 3 years ago

Support Team
Posts: 4330

@cheryldimof,

The other issue here was that the same default avatar is showing even for guest users who have their own avatar showing in comments:

Please approve the following comment to allow us to check it: 

https://www.pnwbeyond.com/sequim-lavender-festival-americas-provence-washington-state/#comment-115258

Regarding the issue with switching the tabs. For testing reason please deactivate the Autoptimize plugin, delete all caches and check again. 

 

Reply
cheryldimof
Posts: 19
Customer
(@cheryldimof)
Member
Joined: 1 year ago

Hi, 

OK, I approved the comment.

I had already tried turning off autoptimize, but I tried again, as well as putting Cloudflare into development mode, but the widget tabs still do not switch. I also tried turning off my cookie consent bar to make sure it wasn't somehow blocking the widget but that didn't solve the issue.

Thanks, 

Cheryl

Reply
1 Reply
Elvina
Moderator
(@elvina)
Joined: 11 months ago

Noble Member
Posts: 1215

@cheryldimof,

For further support please deactivate the Autoptimize plugin and let us now.

 

Reply
cheryldimof
Posts: 19
Customer
(@cheryldimof)
Member
Joined: 1 year ago

Ok, 

Sorry it took so long but I was debugging other issues on my site. I have Autoptimize off now, but I do have other caching and minification plugins off that I don't want to disable for any significant length of time.

I tried the widget with those off; the tabs still won't work. I've put a widget back on this page for now:

https://www.pnwbeyond.com/washington-state-hobbit-houses/

Also, I went ahead and upvoted the comment that you put on the post mentioned previously so it would show in the widget. The widget is still showing a different avatar than is on the comment.

Thanks, 

Cheryl

Reply
1 Reply
Astghik
Admin
(@astghik)
Joined: 3 years ago

Support Team
Posts: 4330

Hi @cheryldimof,

Now you can activate the Autoptimize again. We've found the reason for the issue. It comes from the active theme. It adds a scrolling on all link elements (<a>).

Below is the function from the active theme that caused the issue:  

function() {
  var $this_link = $(this),
    has_closest_smooth_scroll_disabled = $this_link.closest('.et_smooth_scroll_disabled').length,
    has_closest_woocommerce_tabs = $this_link.closest('.woocommerce-tabs').length && $this_link.closest('.tabs').length,
    has_closest_timetable_tab = $this_link.closest('.tt_tabs_navigation').length,
    has_closest_eab_cal_link = $this_link.closest('.eab-shortcode_calendar-navigation-link').length,
    has_closest_ee_cart_link = $this_link.closest('.view-cart-lnk').length,
    has_acomment_reply = $this_link.hasClass('acomment-reply'),
    is_woocommerce_review_link = $this_link.hasClass('woocommerce-review-link'),
    disable_scroll = has_closest_smooth_scroll_disabled || has_closest_ee_cart_link || has_closest_woocommerce_tabs || has_closest_eab_cal_link || has_acomment_reply || is_woocommerce_review_link || has_closest_timetable_tab;
  if (location.pathname.replace(/^\//, '') == this.pathname.replace(/^\//, '') && location.hostname == this.hostname && !disable_scroll) {
    var target = $(this.hash);
    target = target.length ? target : $('[name=' + this.hash.slice(1) + ']');
    if (target.length) {
      if ($this_link.closest('.et_pb_fullscreen_menu_opened').length > 0) {
        et_pb_toggle_fullscreen_menu()
      }
      setTimeout(function() {
        et_pb_smooth_scroll(target, !1, 800)
      }, 0);
      if (!$('#main-header').hasClass('et-fixed-header') && $('body').hasClass('et_fixed_nav') && $(window).width() > 980) {
        setTimeout(function() {
          et_pb_smooth_scroll(target, !1, 40, 'linear')
        }, 780)
      }
      return !1
    }
  }
}

You should contact the theme support and ask them to fix this issue. 

Reply
Share: