[Solved] Comment form is missing  

  RSS

Davis
(@davis)
Active Member
Joined: 5 months ago
Posts: 10
17/03/2019 1:18 am  

Hi!

I have done everything suggested and the comment form is still missing. My theme is Avada, it seems that you are using this theme too.

Screenshot (1)

This is all the plugins I use. Please help me.

This topic was modified 5 months ago by Tom

Davis
(@davis)
Active Member
Joined: 5 months ago
Posts: 10
17/03/2019 3:57 pm  

My Post Type is Product


Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 3066
18/03/2019 12:09 pm  

Hi @davis,

It seems this custom post type either doesn’t support comments or the template file doesn’t have comment loading functions. Almost all custom post type creator plugins have an option to enable comments in custom post type settings:

If there is no any settings to enable comments, you can use WordPress add_post_type_support() function. You can simply add the following to your active theme functions.php file:

function comment_support_for_my_custom_post_type() {
     add_post_type_support( 'my_post_type', 'comments' );
}
add_action( 'init', 'comment_support_for_my_custom_post_type' );

Davis
(@davis)
Active Member
Joined: 5 months ago
Posts: 10
18/03/2019 3:45 pm  

Thank you for your replay, The product's custom post type is created by the WooCommerce plugin. And I didn't find the option to enable comments in the plugin. But I find the option to enable reviews and check it on.

Screenshot (5)

And I have add the code to my child theme functions.php file, I use the child theme now. But the comment form is still missing.

Screenshot (2)
Screenshot (1)

The plugins I use now are: Affiliates, Affiliates WooCommerce Light, bbPress, Contact Form 7, Easy Digital Downloads, Envato Market, Fusion Builder, Fusion Core, User Menus, WooCommerce, WooCommerce Blocks, WP-Optimize, wpDiscuz. There are no other comment plugins besides wpDiscuz.

The Default Form is enabled for all post types.

Screenshot (3)

The all new posts commenting is enabled

Screenshot (4)

In “Edit Product” admin page, There is no “Discussions” and "Comments" admin-box in the Screen Options, But the"Reviews" admin-box is in the Screen Options, and i check it on.

Screenshot (6)
Screenshot (7)

In “Edit Post” admin page, the “Allow Comments” option is enabled. But still no comment form in front-end page.

Screenshot (9)
Screenshot (8)

Please help me.


Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 3066
18/03/2019 3:54 pm  

Hi @davis,

Please leave some example URL to allow us to check it. 


Davis
(@davis)
Active Member
Joined: 5 months ago
Posts: 10
18/03/2019 5:20 pm  

This is a product page: https://www.bearichman.club/product/make-money/   

This is a post page: https://www.bearichman.club/when-is-creative-too-creative/


Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 3066
18/03/2019 5:24 pm  

Hi @davis,

please register some new user and send the login details to info[at]gvectors.com email address. 

This post was modified 5 months ago by Astghik

Davis
(@davis)
Active Member
Joined: 5 months ago
Posts: 10
18/03/2019 6:54 pm  

Hello, I have sent the login details to the email address.  Please Check it Out.

Looking forward to your reply


Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 3066
18/03/2019 7:33 pm  

@davis,

Please navigate to Dashboard > Comments > Form admin page, make sure you don't disable commenting for roles.

form

Doc for this option here: https://wpdiscuz.com/docs/wpdiscuz-documentation/getting-started/custom-comment-form/comment-form-settings/#disable_commenting_for_roles


Davis
(@davis)
Active Member
Joined: 5 months ago
Posts: 10
18/03/2019 9:21 pm  

Thank you for you reply, I have no disable commenting for any roles.

Screenshot (3)


Davis
(@davis)
Active Member
Joined: 5 months ago
Posts: 10
19/03/2019 12:27 am  

I checked the theme options carefully and I found that I was turn off comments in the Theme Options >Blog > Blog Single Post.

Screenshot (1)

And I turn on it now, The comment form is displayed in the post page now.

But the Product page still missing...

The product page: https://www.bearichman.club/product/make-money/    

The post page: https://www.bearichman.club/when-is-creative-too-creative/


Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 3066
19/03/2019 1:52 pm  

Hi @davis,

I think there is some other option for enabling comments on the product page. Please check one more time themes options. 


Davis
(@davis)
Active Member
Joined: 5 months ago
Posts: 10
19/03/2019 3:46 pm  

I checked it again carefully, but I didn't find the relevant option. This reason can be exhausted.

Please Help Me


Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 3066
20/03/2019 1:37 pm  

Hi @davis,

We don't find such an issue on our test websites. We'll need admin access to debug it. Please send admin login details to info[at]gvectors.com email address. 


Davis
(@davis)
Active Member
Joined: 5 months ago
Posts: 10
20/03/2019 4:39 pm  

Thank you for you help! I have sent it to you email address. Please Check it Out.


Arina
(@arina)
Estimable Member Moderator
Joined: 5 years ago
Posts: 101
20/03/2019 5:25 pm  

Hi @davis,

Now everything is working. We've just unchecked the "Reviews can only be left by verified owners" option from the WooCommerce plugin settings. The option is located in Dashboard > WooCommerce > Settings > Products admin page.

Reviews can only be left by  verified owners

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.


Davis
(@davis)
Active Member
Joined: 5 months ago
Posts: 10
21/03/2019 4:53 am  

Thank you very much, it's prefect!


Astghik liked
Share: