Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum   wpForo Support Forum

[Solved] Invalid Captcha Code  


JohnBDraper
Posts: 7
Customer
(@johnbdraper)
Member
Joined: 3 years ago

I use the Add-on Google Re-Captcha and it worked well for a couple of years. But suddenly, many but not all comments cannot be posted but instead get an error - invalid Captcha code.  I have tried disabling plugins one by one, renewing the Google site and secret codes and nothing helps.  Sometimes I think it's fixed but it comes back.  I have reverted to the code method but the Google system was good.  Any suggestions?

14 Replies
Elvina
Posts: 1039
Moderator
(@elvina)
Noble Member
Joined: 9 months ago

Hi @johnbdraper,

Please leave the example URL to allow us to check it.

7 Replies
JohnBDraper
Customer
(@johnbdraper)
Joined: 3 years ago

Member
Posts: 7

It's currently disabled but it's here: https://www.cobourgblog.com/

 

Elvina
Moderator
(@elvina)
Joined: 9 months ago

Noble Member
Posts: 1039

@johnbdraper,

We've just test it on your website with different browsers, and it works without any errors. Please record a video with the issue leave it here to allow us to see the issue. Just keep open the console to allow us to see if there are any errors.

The topic was moved to the correct subforum.

 

JohnBDraper
Customer
(@johnbdraper)
Joined: 3 years ago

Member
Posts: 7

As I had said, i had disabled the plugin so that the code  version (NOT Recaptcha) was being used because it worked as you discovered.  I have now re-activated the plugin and again - comments cannot be made - bad for the blog but suitable for testing.  please try testing again.

 

JohnBDraper
Customer
(@johnbdraper)
Joined: 3 years ago

Member
Posts: 7

And here is a screen grab

 

Elvina
Moderator
(@elvina)
Joined: 9 months ago

Noble Member
Posts: 1039

@johnbdraper,

Please send the admin login details to info[at]gvectors.com email address to allow us to check it.

 

JohnBDraper
Customer
(@johnbdraper)
Joined: 3 years ago

Member
Posts: 7

I sent the login details 5 hours ago - any progress?  Nobody can comment in the meantime!

Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 4137

@johnbdraper,

The issue is fixed by our developers. Please press CTRL+F5 on the frontend and check it. 

 

JohnBDraper
Posts: 7
Customer
(@johnbdraper)
Member
Joined: 3 years ago

So far looks good - three tests worked.  Thank you.

Astghik
Posts: 4137
Admin
(@astghik)
Support Team
Joined: 2 years ago

@shulamite,

Please navigate to Dashboard > Comments > Settings > Addons > Google reCAPTCHA admin page, find the "Request method" option and change the value of the option to "CurlPost", delete all caches and check again. 

If it doesn't help select the values one by one to find the request method that will work fine in your case. 

Press CTRL+F5 (twice) on the frontend each time before checking. 

 

2 Replies
JohnBDraper
Customer
(@johnbdraper)
Joined: 3 years ago

Member
Posts: 7

This morning I found that it works OK - it seems support had already changed that setting to CurlPost so that was the fix.  I now have a whole lot of happy followers.

 

Ali
 Ali
Customer
(@alip)
Joined: 6 months ago

Member
Posts: 13

@astghik This solution worked for me as well.

 

momscientist
Posts: 7
(@momscientist)
Active Member
Joined: 3 months ago

Oh, do you have to purchase the addon for a   Google reCAPTCHA to work?

1 Reply
Tom
 Tom
Admin
(@tomson)
Joined: 5 years ago

Support Team
Posts: 3202

@momscientist,

What plugin you're asking for? For wpDiscuz you should by the wpDiscuz - Google reCAPTCHA addon: https://gvectors.com/product/wpdiscuz-recaptcha/

 

Share: