Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum ย  wpForo Support Forum

[Solved] Don't works with WP Rocket cache  


Laurent
Posts: 22
Customer
(@laurent)
Member
Joined: 2 years ago

Hello,

Nothing works with WP Rocket cache plugin ๐Ÿ™

ScreenShot00833

ย 

14 Replies
Laurent
Posts: 22
Customer
(@laurent)
Member
Joined: 2 years ago
Reply
Laurent
Posts: 22
Customer
(@laurent)
Member
Joined: 2 years ago

And nothing better if I try to exclude js and css folders from the WP Rocket plugin settings.

ย 

/wp-content/plugins/wpdiscuz/themes/default/style.css
/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-combo.min.css
/wp-content/plugins/wpdiscuz-emoticons/assets/third-party/quill-emoji/quill-emoji.min.css

/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-combo.min.js
/wp-includes/js/comment-reply.min.js
Reply
12 Replies
Tom
 Tom
Admin
(@tomson)
Joined: 5 years ago

Support Team
Posts: 3220

@laurent,

Could you please send admin login details to info[at]gvectors.com email address? We'll login and go through all WP Rocket plugin settings. Currently, I see WP Rocket plugin is affecting the jQuery variable, so wpDiscuz has no cache to work.

We need to enable/disable each option of this plugin and find the specific feature which affects wpDiscuz. BTW, you can do that yourself too. But after each option disabling you should delete all caches before checking the result.

 

Reply
Laurent
Customer
(@laurent)
Joined: 2 years ago

Member
Posts: 22

@tomson

Thank you for your reply.

I understand that it's not easy to make everything work the first time with a lot of features enabled on all sites.

If I disable "mimification JS files", everything works.

But with wpDiscuz version 1.x everything worked too, even with this WP Rocket option enabled.
If I disable it, I lose speed for my site and therefore Google "God" ratings ๐Ÿ™

Reply
Tom
 Tom
Admin
(@tomson)
Joined: 5 years ago

Support Team
Posts: 3220

Ok, keep id disabled @laurent,

We're going to test it on our test website and try to find the conflict point.

Reply
Laurent
Customer
(@laurent)
Joined: 2 years ago

Member
Posts: 22

@tomson

Do you want access to my admin to make your test ?

Reply
Tom
 Tom
Admin
(@tomson)
Joined: 5 years ago

Support Team
Posts: 3220

@laurent,

No it's not necessary yet. We'll ask it if it'll be.

In the meantime I recommend go to Dashboardย  > wpDiscuz > Settings > General Settings Tab and disable the first, then second options (test those separately) . Don't forget delete all kind of caches after each option disabling.

  • Load Combo Version
  • Load Min Versions
Reply
Laurent
Customer
(@laurent)
Joined: 2 years ago

Member
Posts: 22

@tomson

I tested:

- By reactivating "Use WordPress native AJAX functions". The problem is still present.
- Disable "Load Combo Version". The problem is still present.
- Disable "Load Min Versions". The problem is still present.

I've been completely purging the cache after each new change.

Reply
Laurent
Customer
(@laurent)
Joined: 2 years ago

Member
Posts: 22

@tomson

Another information: if I disable "wpDiscuz - Emoticons", "wpDiscuz" no longer displays an error.
So I think the problem is "wpDiscuz - Emoticons", if that can help.

Reply
Astghik
Admin
(@astghik)
Joined: 3 years ago

Support Team
Posts: 4210

@laurent,

We've found the reason for the issue. Please, see the description of the issue below. 

The WP Rocket plugin does the wrong minify of the js files. Usually, the minify tools consider that the spaces in the regular expressions shouldn't be cleared. However, the WP Rocket plugin minifying functionality doesn't work correctly.

In the emoticon's addons quill-emoji.js, quill-emoji.min.js  files, there is the following regular expressions / +/g . The WP Rocket plugin removes the space before the + sign in the minification process. So if the expression is without spaces it'll cause the js errors. 

We'd suggest either contact WP Rocket plugin support and aks them to solve this or disable the "Minify JavaScript files" option in the WP Rocket plugin settings. 

Reply
Laurent
Customer
(@laurent)
Joined: 2 years ago

Member
Posts: 22

Thank you @astghik

I just contacted the WP Rocket team. I'll let you know as soon as I get an answer.

Reply
Astghik
Admin
(@astghik)
Joined: 3 years ago

Support Team
Posts: 4210

@laurent,

We've found the workaround for such cases. Please update the wpDiscuz Emoticons addon to the latest version (v. 7.0.3) and check again. The issue should be solved. 

Reply
Laurent
Customer
(@laurent)
Joined: 2 years ago

Member
Posts: 22

@astghik

Everything seems to be working perfectly. Excellent work ๐Ÿ˜‰

Should I let the exclusion? ( https://gvectors.com/forum/postid/23578/)

Thank you for your time.

Reply
Astghik
Admin
(@astghik)
Joined: 3 years ago

Support Team
Posts: 4210

@laurent,

Should I let the exclusion? ( https://gvectors.com/forum/postid/23578/)

This is not necessary anymore.

Reply
Share: