Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum wpForo Support Forum

[Solved] Infinite spinner on Private Message screen on mobile

10 Posts
3 Users
1 Likes
70 Views
User77777
Posts: 5
Customer
Topic starter
(@user7777777)
Member
Joined: 2 weeks ago

Hi there, 

I'm experiencing 2 problems with the Private Messaging addon: 

  • Infinite spinner on the private message screen on mobile devices (desktop is fine). See screenshot:
    • infinite spinner pm screen
  • After sending a private message, it does not show up in the message list until I refresh the page. This is a problem on both mobile and desktop.

I have disabled all caching plugins and I have also cleared my Wordpress cache under Hosting Configuration. But the problem persists. 

Any suggestions?

Thanks!

9 Replies
Kyle
Posts: 395
 Kyle
Admin
(@kylew)
Reputable Member
Joined: 1 year ago

Hi @kevin-antonioli,

The issue should be from a JS error of your website, please provide forum URL.

Reply
User77777
Posts: 5
Customer
Topic starter
(@user7777777)
Member
Joined: 2 weeks ago

Hi @kylew, here is the forum URL: https://neondreamzunderground.com/community/

Thanks

Reply
3 Replies
Tom
 Tom
Admin
(@tomson)
Joined: 7 years ago

Famed Member
Posts: 3977

@kevin-antonioli,

This is a cache issue, you should exclude some more paths from your cache plugin. Please read my reply here: https://gvectors.com/forum/wpforo-private-messages/after-updating-plugins-private-messages-have-an-infinite-spinner/#post-33389

Reply
User77777
Customer
(@user7777777)
Joined: 2 weeks ago

Member
Posts: 5

@tomson I don't use any third party cache plugins. I do use Page Optimize (managed by WordPress) and I also use Jetpack boost. I didn't see those in the list provided at the link. Any suggestions?

Reply
Tom
 Tom
Admin
(@tomson)
Joined: 7 years ago

Famed Member
Posts: 3977

@kevin-antonioli,

In any case, please disable Page Optimizing (managed by WordPress) and Jetpack boost to test.

Reply
Kyle
Posts: 395
 Kyle
Admin
(@kylew)
Reputable Member
Joined: 1 year ago

@kevin-antonioli,

I see that you have JS error in your website, please fix that.

Reply
User77777
Posts: 5
Customer
Topic starter
(@user7777777)
Member
Joined: 2 weeks ago

Hi Kyle, I imagine there are some paths/files I need to exclude from the Page Optimizer plugin. Do you happen to know which ones? I've attached a screenshot of the Page Optimizer settings page. I'd rather not disable the plugin completely if I can avoid it, since it helps the loading times on my site.

PageOptimizerSettings

 

 

Reply
2 Replies
Tom
 Tom
Admin
(@tomson)
Joined: 7 years ago

Famed Member
Posts: 3977

@kevin-antonioli,

First, please disable all caches and disable both plugins to make sure the issue comes from them. If so, it's better to disable the concatenate JS and CSS. This has a minimal affection on the page speed, so it's not so important.

Reply
User77777
Customer
(@user7777777)
Joined: 2 weeks ago

Member
Posts: 5

@tomson Disabling concatenation of CSS and JS within Page Optimizer worked. Good to go now, thanks!

Reply
Share:
Scroll to top