[Solved] Advanced Attachments Works Only For Admin  


8Anne8
Posts: 4
(@8anne8)
New Member
Joined: 5 months ago

Hi,

So I have purchased the Advanced Attachments Add On but it only works only for admin.

Is there an option I should have enabled. I looked through documentation and couldn't find anything.

Thanks!

Topic Tags
6 Replies
Astghik
Posts: 3079
Admin
(@astghik)
Support Team
Joined: 2 years ago

Hi @8anne8,

Attach file button is only available for Usergroups who have “Can attach file” permissions in granted forum access. So please edit Forum accesses and make sure the "Can attach file" option is checked.

Also, wpForo has a built-in spam control system. It controls new registered users and allows to attach a file when the user has X number of approved posts. Please manage this setting in Dashboard > Forums > Tools > Antispam > New Registered user section.

8Anne8
Posts: 4
(@8anne8)
New Member
Joined: 5 months ago

Hi Astghik,

It still doesn't work. I believe this is because users actually register through WishList Member. So the users are not in members in WP Foro.

I went to Forum Access and everyone had already permission to attach. Is there another way?

Thanks a lot!

Anne

 

1 Reply
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3079

Hi @8anne8,

Please navigate to Dashboard > Forums > Dashboard admin page, click on [Synch User Profiles] button. 

Then make sure you've checked both points mentioned here: https://gvectors.com/forum/wpforo-advanced-attachments/advanced-attachments-works-only-for-admin/#post-14612

Especially navigate to Dashboard > Forums > Tools > Antispam > New Registered user section set 0 for the "Min number of posts to be able attach files" option. 

Min number of posts to be able attach files

8Anne8
Posts: 4
(@8anne8)
New Member
Joined: 5 months ago

It works now!

Thank you so much!

Anne

 

 

8Anne8
Posts: 4
(@8anne8)
New Member
Joined: 5 months ago

oh, forgot to ask you this. Do I need to click on [Synch User Profiles] button every time a new user is registered? So he/she can attach files? or maybe the main issue was Dashboard > Forums > Tools > Antispam > New Registered user section set 0 for the "Min number of posts to be able attach files" option?

1 Reply
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3079

I think the main issue is the value of the "Min number of posts to be able attach files" option. Just leave the value 0. 

Share: