Notifications
Clear all

iPhone Large Images won’t attach

21 Posts
4 Users
0 Likes
957 Views
Posts: 8
Customer
Topic starter
(@collin-hensley)
Member
Joined: 2 years ago

 

374B2C24 FA4B 42A4 BB7A 2335553C68D6

 

A9059D54 5064 4CA1 B449 967DF4B4C2CB

Hi, I think I’ve reached out about the same issue before, but it still hasn’t been resolved.

I am unable to attach images from my iPhone to comments. If I change the size of the image during the upload process from “Actual Size” to “Large”, it uploads just fine. But the default Actual Size doesn’t upload. However, what is weird is the image still uploads to the Media Library and can be seen on the backend. When I’m uploading 
the Actual Size image, it just spins and spins and the thumbnail image never shows under the comment.

its not realistic to instruct my users to modify the image size before uploading.

I am attaching an example image that won’t work as well as a screenshot of the different image sizes I can choose while uploading. I am trying to upload from an iPhone 12. Also, I am uploading this image to this comment from my phone and it is attaching just fine. Has to be something in some setting in my site.

20 Replies
Posts: 4176
 Tom
Admin
(@tomson)
Famed Member
Joined: 9 years ago

Hi @collin-hensley,

This is a server limitation and configuration issue, for sure. It would be better to attach that large image to this support topic, so we could test it on our test websites.

Reply
6 Replies
Customer
(@collin-hensley)
Joined: 2 years ago

Member
Posts: 8

@tomson 

Thank you for your reply. I am attaching an iPhone picture to this message for testing. I just migrated my site to Cloudways with Vultr High Frequency. There shouldn’t be any server limitations since the same size photos upload directory into the Media Library and to other templates with no issues. I’m also attaching this large photo to this message and it uploads just fine. 

44025C70 2ACB 4982 8DAE 6B01A6231636

 

Reply
 Tom
Admin
(@tomson)
Joined: 9 years ago

Famed Member
Posts: 4176

Ok, thank you @collin-hensley,

I'll let you know if I got some news for you.

Reply
Customer
(@collin-hensley)
Joined: 2 years ago

Member
Posts: 8

@tomson Hi, any update on this?

Reply
 Tom
Admin
(@tomson)
Joined: 9 years ago

Famed Member
Posts: 4176

Hi @collin-hensley,

I'm sorry, but we don't have any solution for this. The photo works fine for us. This could be even phone issue. Could you please attach the same image using a phone to this topic?

Reply
Customer
(@collin-hensley)
Joined: 2 years ago

Member
Posts: 8

@tomson 

The picture attachment above is from my phone. It may be the photo dimension size or the file size.

Do you have someone who can try to post a comment to my website with a large photo from an iPhone to test?

Reply
 Tom
Admin
(@tomson)
Joined: 9 years ago

Famed Member
Posts: 4176

Hi @collin-hensley,

I'm sorry, but this is something that we cannot support. It depends on the phone, hosting service, lots of PHP configurations, installed plugins and many more. This kind of issues can only be fixed by changing the hosting or by redeveloping the website from scratch.

For example. You should install a fresh WP+wpDiscuz+Meida Uploader addon in a new hosting service and test it. If it works, then install all plugins you have in current website, if it still works then install the theme. This is the only solution.

Reply
Posts: 52
(@mikequinn)
Trusted Member
Joined: 5 years ago

Same issue and it's been driving me nuts going on TWO YEARS. It's not php.ini issues, it's not a plugin issue, and I don't think it's a cloudflare issue. The only thing I can't check easily is litespeed sever settings. And I did mess with those at one time, but that was at the beginning of this fight.

The plugin used to work perfectly. Before 7.0.

Reply
5 Replies
(@mikequinn)
Joined: 5 years ago

Trusted Member
Posts: 52

And here's the irritating bit...all of the attachments get uploaded to the media file. They just don't post to the comment.

Even after you disable the Wordpress 2560px nanny limit.

Reply
(@mikequinn)
Joined: 5 years ago

Trusted Member
Posts: 52

It's definitely got something to do with pixel dimension rather than file size. I played with different Photoshop compression rates and pixel dimensions. Definitely has to do with pixels. 2000 pixels (at 225kb)? No. 1200 pixels at a larger file size (452kb) than the 2000 pixels? Works fine.

It happens all on devices.

Reply
(@mikequinn)
Joined: 5 years ago

Trusted Member
Posts: 52

After about 30 tests using the same image, I dialed in at 1537 x  1023 pixels (standard 3:2 format) for my site. 1537 pixels good to go. 1538 pixels? Won't post on the comment. No matter the sizes of the files. I doubled 1537 file size to 1.2 mb. Posted just fine. 1538px at 567 KB? Won't post. Now, is it something particular to my site? Something in newer versions of WP? Or something messed up in the plugin? That's Million dollar question.

Reply
(@mikequinn)
Joined: 5 years ago

Trusted Member
Posts: 52

Wait. What do we have here? 1536px in the WPDiscuz media media menu. I have no idea where that is from. I have no media sizes set to that.

Screenshot 2023 06 21 062058

 

Reply
(@mikequinn)
Joined: 5 years ago

Trusted Member
Posts: 52

I unclicked that one. Now my upper limit seems to be 1899 pixels. 1900 doesn't load. File size still doesn't make a difference.

Reply
Posts: 52
(@mikequinn)
Trusted Member
Joined: 5 years ago

Ok, if you've made it through the above diatribe; I think we finally figured it out after I narrowed it down to a Litespeed issue.

From my managed hosting provider (Knownhost):

----------------

I implemented the LiteSpeed-focused solution from here but it wasn't working in my testing.
---
https://support.cpanel.net/hc/en-us/articles/360055620893-WordPress-image-upload-error-Post-processing-of-the-image-likely-failed-because-the-server-is-busy

Memory Soft Limit: 4097M
Memory Hard Limit: 4098M
---

It's possible cache was interfering on my end. I'm glad it is working for you now. Please let us know if you need anything else.

Thanks,

Reply
2 Replies
(@mikequinn)
Joined: 5 years ago

Trusted Member
Posts: 52

Maybe look into that a bit on gvectors end and add it to the documentation? And maybe it helps out OP.

Reply
(@mikequinn)
Joined: 5 years ago

Trusted Member
Posts: 52

Bottom line is that Litespeed has it's own parameters and limits separate from that found in php.ini.

Reply
Posts: 52
(@mikequinn)
Trusted Member
Joined: 5 years ago

Also need to add this to functions.php and remove the WP 2560 px limit (from here: https://foliovision.com/2021/11/full-size-images-wordpress):

function td_big_image_size_threshold( $threshold, $imagesize, $file, $attachment_id ) {
    return 4096;
}
add_filter( 'big_image_size_threshold', 'td_big_image_size_threshold', 10, 4 );
Reply
3 Replies
(@mikequinn)
Joined: 5 years ago

Trusted Member
Posts: 52

And then go back with something like Shortpixel and make them smaller in pixels and compression if desired.

Reply
(@mikequinn)
Joined: 5 years ago

Trusted Member
Posts: 52

My shortpixel setting (the image optimization plugin, not their on the fly CDN service):

Screenshot 2023 06 21 223947

That takes a 4032 (wide) pixel image at 1.2 mb down to 2287 × 1715 pixels and 456kb on their "lossless" setting. Still plenty of detail for a light box and a high res screen. You can make it smaller in pixel size and up the compression (i.e. glossy) for more squeeze if you need it.

Other plugins can probably do similar things...but I've used Shortpixel for a while and it just works...and most importantly, it works with a WPDiscuz, Litespeed, and can communicate directly with Cloudflare with a token.

Reply
Astghik
Admin
(@astgh)
Joined: 6 years ago

Illustrious Member
Posts: 5944

Thank you for taking the time and share the information. We really appreciate it.

Reply
Share:
Scroll to top