Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum   wpForo Support Forum

Permit commenters to reply to other commenters  

  RSS

richards1052
(@richards1052)
Active Member
Joined: 2 years ago
Posts: 12
15/06/2018 3:49 am  

My commenters are telling me there is no way to reply to a specific comment and have it show up underneath or related to that previous comment.  Every comment is merely listed in chronological order.  This makes it harder for readers to follow the thread.  Is there any setting for the plugin that permits this?


Quote
Astghik
(@astghik)
Support Team Admin
Joined: 3 years ago
Posts: 4338
15/06/2018 9:43 am  

Hi richards1052,

Make sure the "Enable threaded (nested) comments [X] levels deep" is enabled. 

More info you can find here:

https://wpdiscuz.com/docs/wpdiscuz-documentation/discussion-settings/comment-display-settings/#nested_comments

 


ReplyQuote
richards1052
(@richards1052)
Active Member
Joined: 2 years ago
Posts: 12
15/06/2018 11:16 am  

That's my default setting. I've always had nested comments in my WP settings.  That all changed when I installed the plugin which somehow superceded that setting.


ReplyQuote
richards1052
(@richards1052)
Active Member
Joined: 2 years ago
Posts: 12
15/06/2018 11:28 am  

If you look at this post & comment thread you can see that the comments are not nested even though commenters are commenting on each other's comments:

https://www.richardsilverstein.com/2018/06/10/israeli-dirty-ops-firms-colluded-on-trumps-behalf-perhaps-directed-by-israeli-government/#comments


ReplyQuote
Astghik
(@astghik)
Support Team Admin
Joined: 3 years ago
Posts: 4338
15/06/2018 2:05 pm  

richards1052,

I see Jetpack comments on your website. This is the problem. Please deactivate Jetpack comments, delete cache and all will work fine.


ReplyQuote
richards1052
(@richards1052)
Active Member
Joined: 2 years ago
Posts: 12
15/06/2018 10:57 pm  

Thanks!!


ReplyQuote
richards1052
(@richards1052)
Active Member
Joined: 2 years ago
Posts: 12
16/06/2018 11:39 am  
screenshot www.richardsilverstein.com 2018.06.16 00 37 14

Is this how the Jetpack Discussion settings should look when I turn Comments off?


ReplyQuote
richards1052
(@richards1052)
Active Member
Joined: 2 years ago
Posts: 12
16/06/2018 12:08 pm  

I have deleted the cache after changing the Jetpack Comment settings.  But the comments are still not threaded.


ReplyQuote
Astghik
(@astghik)
Support Team Admin
Joined: 3 years ago
Posts: 4338
16/06/2018 1:02 pm  

Hi  richards1052,

The HTML structure is not wpDiscuz HTML structure.

Please switch to the default theme and check again. This may be the theme issue.

Also, deactivate all plugins one by one and check after each deactivation.

wpDiscuz
Pay attention to noscript tag

 


ReplyQuote
richards1052
(@richards1052)
Active Member
Joined: 2 years ago
Posts: 12
17/06/2018 12:18 pm  

I just disabled a comment plugin called FV comment.  Can you check whether that's made a difference?

Now I've noticed I can see a "view replies" option.  But is there a way to see replies  as a thread by default rather than having to click the icon to see them?


ReplyQuote
Astghik
(@astghik)
Support Team Admin
Joined: 3 years ago
Posts: 4338
17/06/2018 12:58 pm  

I see that now everything works fine. Please don't use other comment plugins.

testing

Now I've noticed I can see a "view replies" option.  But is there a way to see replies  as a thread by default rather than having to click the icon to see them?

Please disable the "Display only parent comments and view replies ∨ button" option. 

More info here:

https://wpdiscuz.com/docs/wpdiscuz-documentation/settings/comment-list-settings/#view-replies


ReplyQuote
richards1052
(@richards1052)
Active Member
Joined: 2 years ago
Posts: 12
18/06/2018 3:31 am  

Great!  Things are now looking good.  Appreciate your help!


ReplyQuote
Share: