Google ReCaptcha is now asking users to select traffic lights and storefronts  


ryansmccain
Posts: 11
Customer
(@ryansmccain)
Member
Joined: 12 months ago

I only want people to have to check the NOT A ROBOT box. I don't want people to have to select storefronts and streetlights. This used to work fine. 

You can click on any post here and test it yourself:  https://www.InterestingAnswers.com

thanks

4 Replies
Astghik
Posts: 1972
Admin
(@astghik)
Support Team
Joined: 1 year ago

Hi @ryansmccain,

This generates by Google reCaptcha. In my case, as you can see in the video, it doesn't ask to select traffic lights and storefronts.

https://www.screencast.com/t/mzstfTNERGHE

Also, you need to exclude wpDiscuz files from WP Rocket plugin settings, as the reCAPTCHA appears after the page refreshing. 

This article should help you:

https://docs.wp-rocket.me/article/915-find-the-right-js-files-to-exclude-from-minification

Reply
1 Reply
ryansmccain
Customer
(@ryansmccain)
Joined: 12 months ago

Member
Posts: 11

Thanks for the response. That's weird that it didn't happen for you. Hmm.

Anyways, can you just tell me what files to exclude rather than me having to figure it out? Thanks again.

Reply
Astghik
Posts: 1972
Admin
(@astghik)
Support Team
Joined: 1 year ago

@ryansmccain,

you need to exclude wpdiscuz.css/wpdiscuz,js files. 

Please read the article, I've provided in the previous post. 

Reply
ryansmccain
Posts: 11
Customer
(@ryansmccain)
Member
Joined: 12 months ago

I did read it. I thought I missed the actual answer in there so that's why I asked again. I was looking for an answer, not a document on how to find the answer. 

I don't have a red error when I bring up console so the document didn't seem to apply here.

I will for sure learn the contents of the article this week, though.

Thanks!

Reply
Share: