Notifications
Clear all

Usergroup in Account Page  


Mark
Posts: 17
 Mark
Customer
(@mark-sr)
Member
Joined: 2 months ago

Good day Support!

The hierarchy of my users are the following:

1. Subscriber->SiteAdmin

2. Subscriber->Pending

3. Subscriber->Approved

 

in wpforo I created a usergroup called:

SiteAdmin = Who can approve new member, can manage the forum topic and anything related to forum(User role: Subscriber:Default Forum Access:Full Access)

Pending = Member who registered the forum but still need to upload requirements(User role:Subscriber:Default Forum Access:Few items selected) No access to forum

Approved = Member who registered the forum and uploaded all requirement needed(User role: Subscriber:Default Forum Access:Several items selected) Can access the forum

Goal = SiteAdmin should able to change the usergroup from Pending to Approved so that they will be able to interact the forum. Why I am not giving Administrator WP User Role because I do not want them to touch my wordpress core, to see the dashboard and other wordpress functionality. I want them to work only anything related to member of the forum and the forum topic.

Problem is your Usergroup is not showing to user with SiteAdmin access it only appear when the member have Administrator in WP User Role .  With your kindness find solution to this one without waiting your next version release please, any workaround is very much appreciated.

Note:  Member who registered the site is automatically have  a Subscriber User Role.

 

Kind regards

7 Replies
Astghik
Posts: 3831
Admin
(@astghik)
Support Team
Joined: 2 years ago

Hi @mark-sr

I'll ask the developers this question and let you know asap.

Reply
6 Replies
Mark
 Mark
Customer
(@mark-sr)
Joined: 2 months ago

Member
Posts: 17

@astghik

I appreciate it a lot, I am patiently waiting

 

Thanks

 

Reply
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3831

@mark-sr,

You should edit the  SiteAdmin usergroup and enable the "Dashboard - Manage Usergroups"  permission/CAN. 

Then navigate to Dashboard > Forums > Dashboard admin page, one by one click on "Delete User Cache" and "Delete All Caches" buttons.

If you have some other cache plugins delete those plugins caches as well.

Reply
Mark
 Mark
Customer
(@mark-sr)
Joined: 2 months ago

Member
Posts: 17

@astghik

Thank you for your reply, before contacting you I items are selected:

usergroup

and login as SiteAdmin but the usergroup doesn't show.

 

Reply
Mark
 Mark
Customer
(@mark-sr)
Joined: 2 months ago

Member
Posts: 17
Posted by: @astghik

@mark-sr,

You should edit the  SiteAdmin usergroup and enable the "Dashboard - Manage Usergroups"  permission/CAN. 

Answer: This is done

Then navigate to Dashboard > Forums > Dashboard admin page, one by one click on "Delete User Cache" and "Delete All Caches" buttons.

Answer: I do not have "Dashboard admin page"  and I cannot find the "Delete User Cache" and "Delete All Caches" Can you give me the direct link?  I do not use any caching plugins just yet because still finalizing the development of my website.

If you have some other cache plugins delete those plugins caches as well.

 

Reply
Mark
 Mark
Customer
(@mark-sr)
Joined: 2 months ago

Member
Posts: 17

@astghik 

I am waiting your reply soon.

 

Thank you

 

Regards

Reply
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3831

@mark-sr,

Please wait for the next update (no ETA). This will be fixed. 

 

Reply
Share: