Notifications
Clear all

[Solved] Translation and mark as read redirect

9 Posts
2 Users
1 Likes
793 Views
Posts: 6
Topic starter
(@almeidabr)
Active Member
Joined: 4 years ago

Hi

 

When a visitor likes a comment, it says "Someone liked your coment" how Do I translate "Someone"?

 

When I click on "Mark as Read" it redirects you to the notification, is it the way it is supposed to work? Shouldn't it just delete the notification instead of redirecting to the notification since you already have a link to the notification if you want to see it?

 

Thanks!

8 Replies
Astghik
Posts: 5842
Admin
(@astgh)
Illustrious Member
Joined: 6 years ago
Posted by: @almeidabr

When a visitor likes a comment, it says "Someone liked your coment" how Do I translate "Someone"?

The phrase can be translated using the Loco Translate plugin. 

When I click on "Mark as Read" it redirects you to the notification, is it the way it is supposed to work? Shouldn't it just delete the notification instead of redirecting to the notification since you already have a link to the notification if you want to see it?

This is designed to work in this way. You can delete the [MARK_READ_URL] shortcode in the Notifications' Texts, so the button won't be visible anymore. 

Another option I may suggest you check is the "Set notifications as [READ] on load" option. You can enable it if you want. 

7 Replies
(@almeidabr)
Joined: 4 years ago

Active Member
Posts: 6

@astgh Thanks! Is there anything specific that I have to do to create the translation? I tried translating "Someone" still shows "Someone"

(@almeidabr)
Joined: 4 years ago

Active Member
Posts: 6
Astghik
Admin
(@astgh)
Joined: 6 years ago

Illustrious Member
Posts: 5842

@almeidabr,

Please let us know if you've deleted all caches before checking? 

(@almeidabr)
Joined: 4 years ago

Active Member
Posts: 6

@astgh Yes both wordpress cache and cloudflare

Astghik
Admin
(@astgh)
Joined: 6 years ago

Illustrious Member
Posts: 5842

@almeidabr,

Please make sure the translated phrases are located in the languages/plugins/wpdiscuz-user-notifications-ru_RU.po file. 

Please watch this small video interaction: https://www.screencast.com/t/EjVKsnuv30X

(@almeidabr)
Joined: 4 years ago

Active Member
Posts: 6

@astgh Thanks! Changing the location worked

Astghik
Admin
(@astgh)
Joined: 6 years ago

Illustrious Member
Posts: 5842

@almeidabr,

Thank you for letting us know. Glad to hear that the issue is solved.

We're going to mark this thread as resolved. Feel free to open a new topic if you have further questions.

Share:
Scroll to top