not letting me add API key  


aorchard
Posts: 13
Customer
(@aorchard)
Member
Joined: 12 months ago

hi there, to try and solve the problem with translation on my site I removed the plugin and reinstalled it, but now it will not let me enter an API key for either yandex or Google. It puts a red cross against it. Translate is no longer showing up. Please can you help. thanks.

Site example here: https://puro.coop/consumers/biologiko-xorio/

15 Replies
Astghik
Posts: 3391
Admin
(@astghik)
Support Team
Joined: 2 years ago

Hi @aorchard,

We couldn't find such an issue on our test websites. We'll need admin access to check it. Please send the admin login details to info[at]gvecrors.com email address. 

Reply
Astghik
Posts: 3391
Admin
(@astghik)
Support Team
Joined: 2 years ago

Hi @aorchard,

For some reason, your server blocks requests with curl URL. It seems some security plugins blocks it.  We recommend deactivate the plugins one by one and check after each deactivation. Also please check your server settings as well and make sure there are not any restrictions. 

Reply
5 Replies
aorchard
Customer
(@aorchard)
Joined: 12 months ago

Member
Posts: 13

Hey there, thanks. But I disabled all plugins and the host company set Curl for php 7.2 and still the same problem... urgently need this fixed now as tomorrow it goes live at an event.. thank you

Reply
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3391

Hi @aorchard,

We've checked and faced with the following issues. 

Issue realated to overloding of server:

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>503 Service Unavailable</title>
</head><body>
<h1>Service Unavailable</h1>
<p>The server is temporarily unable to service your
request due to maintenance downtime or capacity
problems. Please try again later.</p>
</body></html>  blocks requests with curl URL issue. 

cURL error 7: Failed connect to translate.yandex.net:443; Operation now in progress

Please note you cannot use both Google and Yandex translation tool, you should choose the only one of them. Please let us know which one do you choose.

Reply
aorchard
Customer
(@aorchard)
Joined: 12 months ago

Member
Posts: 13

Thanks for looking into this. I prefer Yandex, but it will not remove the Google one...

What do I need to ask of the host company?

Thanks

Reply
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3391

@aorchard,

Please copy the Google key and save it to a file on your computer so as not to lose it.

Then open your website database manager (phpMyAdmin). 

In the wp_options table find the translate_settings option name and replace the value with this one: 

a:6:{s:3:"api";s:6:"yandex";s:5:"valid";s:1:"1";s:3:"key";s:84:"trnsl.1.1.20190313T115437Z.c16e1e1f375d55ca.a442564f55f229e607209a25f207f7b734a471ab";s:18:"trns_form_bg_color";s:7:"#FFFFFF";s:22:"trns_form_border_color";s:7:"#333333";s:27:"trns_text_bottom_line_color";s:7:"#CCCCCC";}

Please note the wp_ is just a prefix in your case it can differ. 

Translation issue

Reply
aorchard
Customer
(@aorchard)
Joined: 12 months ago

Member
Posts: 13

Ok I have done this. The translate now appears again, but when I click it, it is lagging and does nothing. Are you saying this is owing to the server?

Reply
Tom
Posts: 2951
 Tom
Admin
(@tomson)
Support Team
Joined: 4 years ago
 
I recommend you to ensure that your site meet actual requirements for secure connections. Your server must be able to perform connections using SHA-2 and TLS 1.2, as this is required for third-party services as PayPal, Stripe, Authorize.net and many others that are using the HTTPS protocol to ensure privacy in connections to their services. So make a favor to yourself and ensure that your site is hosted on a server with at least cURL version 7.34.0 or higher, OpenSSL/1.0.1 or higher (another library) and also a recent version of PHP, currently 7.0 is the recommended choice.
 

If you already checked that you’re running the recent versions mentioned above. Other common causes at server side for this error are:

  • Plugin conflict, we recommend deactivate all plugins (excerpt the addon and wpDiscuz) and try to activate it again.
  • Issues with the DNS resolving (your server is not able to resolve the IP for the third-party domain or at least not in time).
  • Firewalls or security modules (e.g. mod_security ) blocking the outgoing request.
  • Your host is not able to “talk” with the third-party server due to unavailable required protocols. This can occur if the server has a recent cURL/OpenSSL but it’s not correctly configured to use TLS 1.2 as SSL procotol.
  • Network issues (something at network level prevents your server to reach the yandex.ru server). Please contact to hosting services support and make sure they don't block connections to Yandex server.
Reply
aorchard
Posts: 13
Customer
(@aorchard)
Member
Joined: 12 months ago

Thank you. There used to be "phrases" but now it has disappeared... so I don't seem able to translate messages sent to subscribers. 

Reply
6 Replies
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3391

@aorchard,

You've enabled the "Use Plugin .PO/.MO files" option. In this case, you should translate phrases using Loco Translate plugin. 

Reply
aorchard
Customer
(@aorchard)
Joined: 12 months ago

Member
Posts: 13

damn.. ok and to translate the automated email sent to a person when they add a comment? it was so easy through

Also how to remove the code on this page?

https://puro.coop/consumers/biologiko-xorio/

It says "you can not delete default field" when I try to remove from wpdiscuz / forms

Reply
aorchard
Customer
(@aorchard)
Joined: 12 months ago

Member
Posts: 13

I fixed most of these things now. so no need to reply. thanks for your help.

But the translate link on comments still not working... just hangs.

Reply
Tom
 Tom
Admin
(@tomson)
Joined: 4 years ago

Support Team
Posts: 2951

You have many JS errors on website and those affect Translate button.

Main Errors come from lazy-load-for-comments plugin, please disable this plugin and delete all caches.

2019 03 14 2238

Reply
aorchard
Customer
(@aorchard)
Joined: 12 months ago

Member
Posts: 13

thanks for your reply. I did just this, but still the same problem...

Reply
Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 3391

Ok, we see now it works and sends a request to Yandex, but it returns an error so please continue to check the points mentioned in Tom's posts, the problem in your server cURL configuration. 

In case you couldn't fix this issue we have to refund this addon the Translation addon. Just let us know. 

Reply
Share:
Green
Default
Pear
Black Emo
{green}:grinning:
{green}:wink:
{green}:face:
{green}:inlove:
{green}:sweaty:
{green}:surprised:
{green}:lovekiss:
{green}:laugh:
{green}:formalsmile:
{green}:displeased:
{green}:cool:
{green}:resent:
{green}:nerd:
{green}:screaming:
{green}:amazed:
{green}:sad:
{green}:deceitful:
{green}:starryeyes:
{green}:evil:
{green}:shocked:
{green}:tears:
{green}:sulky:
{green}:smile:
{green}:vomited:
{green}:hi:
{green}:afraid:
{green}:crazy:
{green}:rabid:
{green}:fighting:
{green}:nonoise:
{green}:blushed:
{green}:idontknow:
{green}:scared:
{green}:razz:
{green}:kiss:
{green}:eat:
{green}:shutmouth:
{green}:gape:
{green}:suspicious:
{green}:laughingoutloud:
{green}:bruise:
{green}:crying:
{green}:pray:
{green}:serious:
{green}:excitement:
:)
:d
:wink:
:mrgreen:
:neutral:
:twisted:
:arrow:
:shock:
:???:
:cool:
:evil:
:oops:
:razz:
:roll:
:cry:
:eek:
:lol:
:mad:
:sad:
:!:
:?:
:idea:
:hmm:
:beg:
:whew:
:chuckle:
:silly:
:envy:
:shutmouth:
{pear}:happy:
{pear}:smile:
{pear}:laugh:
{pear}:laughingoutloud:
{pear}:crying:
{pear}:exhausted:
{pear}:nerd:
{pear}:surprised:
{pear}:veryhungry:
{pear}:wink:
{blackemo}:laughtertotears:
{blackemo}:gift:
{blackemo}:love:
{blackemo}:inlove:
{blackemo}:shamefaced:
{blackemo}:heart:
{blackemo}:crazy:
{blackemo}:anguished:
{blackemo}:bruise:
{blackemo}:easymoney:
{blackemo}:exhausted:
{blackemo}:vampire:
{blackemo}:shutmouth:
{blackemo}:wink:
{blackemo}:carnival:
{blackemo}:flowers:
{blackemo}:hotdrink:
{blackemo}:party: