[Solved] I made payment for 3 wpforo add-ons but still not received  

  RSS
phanduykhanh1311
(@phanduykhanh1311)
Member Customer
Payment/Order information
Billing Information 

Ordered item(s) Unit Price Total
1 x wpForo - myCRED Integration - Single Site License 20.00 USD 20.00 USD
1 x wpForo Embeds - Single Site License 8.80 USD 8.80 USD
1 x wpForo Polls - Single Site License 20.00 USD 20.00 USD
Sales Tax / VAT 0.00 USD
Grand Total 48.80 USD
You can access your products according to the terms and conditions you accepted during purchase.

2checkout sent me the confirmation.

However, it's still payment pending in my account. And I have no links to download the plugin.

Please help to check.

Thanks.

Posted : 08/04/2019 8:59 am
phanduykhanh1311
(@phanduykhanh1311)
Member Customer

Please help!

In my account, the status is now Cancelled but I've already made payment via 2checkout.

Screenshot 2

Posted : 08/04/2019 11:11 am
Tom
 Tom
(@tomson)
Support Team Admin

Hi @phanduykhanh1311,

Thank you for your purchase and for contacting us. It seems you've not clicked on [Complete Order] button after the payment step. This button sends information back to gVectors Store for further processes. We just did it manually and your order is set complete. You should receive an email with product download link and activation key. The same information exists in gVectors.com > Your Account page.

Posted : 08/04/2019 12:34 pm
phanduykhanh1311
(@phanduykhanh1311)
Member Customer
Posted by: Tom

Hi @phanduykhanh1311,

Thank you for your purchase and for contacting us. It seems you've not clicked on [Complete Order] button after the payment step. This button sends information back to gVectors Store for further processes. We just did it manually and your order is set complete. You should receive an email with product download link and activation key. The same information exists in gVectors.com > Your Account page.

Thank you much.

I've received the download link.

Posted : 08/04/2019 2:29 pm
Share: