[Solved] wpDiscuz for LearnDash comments  

  RSS

ianlearobinson
(@ianlearobinson)
New Member
Joined: 9 months ago
Posts: 2
03/01/2019 8:58 am  

Hi JDalen,

I am trying desperately trying to get the WPDiscuz comments to replace the default LearnDash comments on each page. How did you get them to show up? I see you are trying to limit them but I want them on every page as you do. Help help help! 

I attached two different page types from my website. One is a learndash lesson and the other is a blog post. I want WPDiscuz to appear on all learndash lessons/topics/courses as they do on the blog post. 

Screen Shot 2019 01 02 at 9.55.41 PM
Screen Shot 2019 01 02 at 9.56.11 PM

Thank you, 

Ian 


Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2950
03/01/2019 10:15 am  

Please navigate to Dashboard > Comments > Forms admin page, edit the default form and make sure it's enabled for all post types: https://wpdiscuz.com/docs/wpdiscuz-documentation/getting-started/custom-comment-form/comment-form-settings/#post-types


LT
 LT
(@lanetownsend)
Active Member
Joined: 3 months ago
Posts: 7
23/06/2019 1:17 am  

I've just discovered wpDiscuz and like it a lot; also a LearnDash user. Tom's instructions had no effect for me for some reason. I did, however, find where a change should be made.

With the Plugin Editor, change this file:

\learndash-v3.0.5.1\sfwd-lms\themes\ld30\templates\focus\index.php

Replace lines 52 through the comment on line 73 with:

<?php comments_template() ?>

to enable wpDiscuz in LearnDash 3.0 Focus Mode.


Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 3282
25/06/2019 3:38 pm  

Hi @lanetownsend,

First of all, thank you for using wpDiscuz.

I really appreciate you taking time and share the information. 


LT
 LT
(@lanetownsend)
Active Member
Joined: 3 months ago
Posts: 7
25/06/2019 6:42 pm  

My pleasure, @Astghik. I also put the following snippet together that enables wpDiscuz in LearnDash 3.0 Focus Mode, but without editing the LD source file directly as mentioned earlier.

add_filter('learndash-focus-content-content-after', 'ld_wpdiscuz_comments_enable');
function ld_wpdiscuz_comments_enable(){
comments_template();
};

 


CultivaTusIdeas
(@cultivatusideas)
New Member
Joined: 1 month ago
Posts: 2
07/08/2019 4:30 am  

@lanetownsend

Hello! I tried your code and it worked. The comments form is now showing inside the focus mode, at the bottom; but even though the comments for the topic are open, when focus mode is set to active, i get the message "comments are closed".  Then if i switch focus mode off, the comments appear as normal, but then focus mode on again (never closing messages from the topic editing screen) and "the comments are closed" message appears again.

¿Have you experienced this? We are using Hello theme with elementor pro. 


LT
 LT
(@lanetownsend)
Active Member
Joined: 3 months ago
Posts: 7
08/08/2019 2:03 am  

@cultivatusideas @astghik

I haven't encountered exactly the same thing, but you may start by double checking a few options. Perhaps start with switching to a different theme other than Hello to see if the problem still exists. If so, switch back to Hello and try the following.

Also check that comments are enabled via WP-Admin › Settings › Discussion. Look at the top for the section, "Default Article Settings," and make sure the option is checked for, "Allow people to post comments on new articles."

Next, check that comments are enabled via WP-Admin › LearnDash › Topics. Choose the "Settings" tab at the top (next to "All Topics"), and at the bottom of the page in the "Topic Custom Post Type Options" meta-box, you'll see the option for "Editor Supported Settings." Make sure comments are enabled here as well by checking the box.

Lastly, check to see if you can enable wpDiscuz via WP-Admin › Comments › WPDISCUZ › Forms. Click on the form you're using and on the resulting page there will be a section labeled, "Display comment form for post types," where you should find a checkbox next to "sfwd-topics." Make sure this box is checked, too.

(Don't forget to save your changes when working with any of the above options.)

Let me know if these ideas make any difference. Try them methodically (one-by-one) so you know which had an effect and which didn't. These ideas may not work, but it's a good place to start before we get our hands dirty in additional custom code, yes?


CultivaTusIdeas
(@cultivatusideas)
New Member
Joined: 1 month ago
Posts: 2
09/08/2019 3:26 am  

@lanetownsend

We already solved it. Thank you for the response! None of what you wrote worked, but we managed to solve it with the info found here: https://developerscodex.com/enable-learndash-comments-in-focus-mode/

Hope this helps others who experience this issue.


LT
 LT
(@lanetownsend)
Active Member
Joined: 3 months ago
Posts: 7
11/08/2019 9:29 pm  

@cultivatusideas

Awesome! Great find. I'll give that solution a try as well. Glad you got it worked out!


Share:
Green
Default
Pear
Black Emo
{green}:grinning:
{green}:wink:
{green}:face:
{green}:inlove:
{green}:sweaty:
{green}:surprised:
{green}:lovekiss:
{green}:laugh:
{green}:formalsmile:
{green}:displeased:
{green}:cool:
{green}:resent:
{green}:nerd:
{green}:screaming:
{green}:amazed:
{green}:sad:
{green}:deceitful:
{green}:starryeyes:
{green}:evil:
{green}:shocked:
{green}:tears:
{green}:sulky:
{green}:smile:
{green}:vomited:
{green}:hi:
{green}:afraid:
{green}:crazy:
{green}:rabid:
{green}:fighting:
{green}:nonoise:
{green}:blushed:
{green}:idontknow:
{green}:scared:
{green}:razz:
{green}:kiss:
{green}:eat:
{green}:shutmouth:
{green}:gape:
{green}:suspicious:
{green}:laughingoutloud:
{green}:bruise:
{green}:crying:
{green}:pray:
{green}:serious:
{green}:excitement:
:)
:d
:wink:
:mrgreen:
:neutral:
:twisted:
:arrow:
:shock:
:???:
:cool:
:evil:
:oops:
:razz:
:roll:
:cry:
:eek:
:lol:
:mad:
:sad:
:!:
:?:
:idea:
:hmm:
:beg:
:whew:
:chuckle:
:silly:
:envy:
:shutmouth:
{pear}:happy:
{pear}:smile:
{pear}:laugh:
{pear}:laughingoutloud:
{pear}:crying:
{pear}:exhausted:
{pear}:nerd:
{pear}:surprised:
{pear}:veryhungry:
{pear}:wink:
{blackemo}:laughtertotears:
{blackemo}:gift:
{blackemo}:love:
{blackemo}:inlove:
{blackemo}:shamefaced:
{blackemo}:heart:
{blackemo}:crazy:
{blackemo}:anguished:
{blackemo}:bruise:
{blackemo}:easymoney:
{blackemo}:exhausted:
{blackemo}:vampire:
{blackemo}:shutmouth:
{blackemo}:wink:
{blackemo}:carnival:
{blackemo}:flowers:
{blackemo}:hotdrink:
{blackemo}:party: