Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum wpForo Support Forum

Twitter not logging in

8 Posts
2 Users
0 Likes
1,106 Views
Andytlaird
(@andytlaird)
Active Member
Joined: 3 years ago
Posts: 5
Topic starter  

I set up the twitter which includes the consumer key and secret. When trying to log in it goes to my Twitter account for confirmation which I approve. I find after going back to the comment section I am not logged into Twitter


   
Quote
Topic Tags
Astghik
(@astgh)
Illustrious Member Admin
Joined: 5 years ago
Posts: 5413
 

Hi @andytlaird,

Please leave some example URL to allow us to check it. 


   
ReplyQuote
Andytlaird
(@andytlaird)
Active Member
Joined: 3 years ago
Posts: 5

   
ReplyQuote
Astghik
(@astgh)
Illustrious Member Admin
Joined: 5 years ago
Posts: 5413
 

Hi @andytlaird

The Twitter login works fine. There is a caching issue caused by the active theme or other plugins. The login shows after the page refreshing. Please watch the video.

https://www.screencast.com/t/txHLBzTMx

 I've checked and found the same issue with FB login. I'd suggest you read this support topic. The same issue is described here: 

https://wordpress.org/support/topic/page-reload-after-social-login/

The problem may be that the scripts in the htaccess file are cached.

In this topic, the user mentioned that his problem was with the htaccess which was cached and caused the issue. Please pay attention to this part as well.


   
ReplyQuote
Andytlaird
(@andytlaird)
Active Member
Joined: 3 years ago
Posts: 5
Topic starter  

Hi

 

My apologies for the late reply. I'm finding that I have to refresh the page to see a logged in user. The only cache I'm using is by Siteground (SG Optimizer) and Cloudflare

This is exactly whats happening with the screencast you sent me.

Is there anything I can do to solve this? I need a cache plugin but I can turn certain parts off in you are able to suggest what? 😉

This post was modified 3 years ago by Andytlaird

   
ReplyQuote
Astghik
(@astgh)
Illustrious Member Admin
Joined: 5 years ago
Posts: 5413
 

Hi @andytlaird,

You should exclude either wpdiscuz.js file or wpdiscuz folder from the SG Optimizer plugin's settings and from Cloudflare. 


   
ReplyQuote
Andytlaird
(@andytlaird)
Active Member
Joined: 3 years ago
Posts: 5
Topic starter  

Hi

Unfortunately I don't see this option in Cloudflare. If I turn of CloudFlare und turn minify on in SG Optimizer I can only add a url here

Excluding URLs
Use this feature if you want to exclude certain parts of your website from being cached and keep them dynamic.  

Would it work adding a URL here and what should I type in?

Appreciate your support

Regards

Andy

 


   
ReplyQuote
Astghik
(@astgh)
Illustrious Member Admin
Joined: 5 years ago
Posts: 5413
 

@andytlaird,

Would it work adding a URL here and what should I type in?

I think you should add the following URL:  wp-content/plugins/wpdiscuz/*

Unfortunately I don't see this option in Cloudflare

I've found the following article please check it: 

https://support.cloudflare.com/hc/en-us/articles/200172316-How-do-I-exclude-a-specific-URL-from-Cloudflare-s-caching-


   
ReplyQuote
Share:
Scroll to top