Forums Censure Pro error whenever banned words are posted  

  RSS

0

Warning: strpos(): Empty needle in /homepages/9/d687739118/htdocs/app747013781/wp-content/plugins/forums-censure-pro/utils/fc-helper.php on line 255

Warning: Cannot modify header information - headers already sent by (output started at /homepages/9/d687739118/htdocs/app747013781/wp-content/plugins/forums-censure-pro/utils/fc-helper.php:255) in /homepages/9/d687739118/htdocs/app747013781/wp-includes/pluggable.php on line 1219

 

I wish I spent half as much of my time actually building my website as I did debugging WordPress plugins.  Very unimpressed with the ecosystem.

 
0

Hi @jsaliga,

We've already fixed this issue, please wait for the update, it'll be released today.

You released an update but it doesn't fix my problem...I installed and activated it and this is what I get whenever I post.

 

Warning: strpos(): Empty needle in /homepages/9/d687739118/htdocs/app747013781/wp-content/plugins/forums-censure-pro/utils/fc-helper.php on line 256

 

Warning: Cannot modify header information - headers already sent by (output started at /homepages/9/d687739118/htdocs/app747013781/wp-content/plugins/forums-censure-pro/utils/fc-helper.php:256) in /homepages/9/d687739118/htdocs/app747013781/wp-includes/pluggable.php on line 1219

 

Seems to me you have some debugging work left to do.

I have no idea why this problem is so difficult for you fix.  You may be trying very hard to resolve it.  Probably are.  But in the meantime I am left with a plugin that I just paid good money for yesterday that generates an error every time someone posts.  I don't think it is quite fair to me.  You have my payment and I have a broken plugin that doesn't work.

 

I have opened a PayPal dispute and will give this a week, and if I don't have working plugin by then I will escalate it to a claim to get my money back.  I'll gladly pay for a plugin that works.  But I am not going to pay for one that doesn't.

0

Hi @jsaliga,

This is not the same error, this is another error with the same case. We're fixing it just now. if you don't have a few hours to wait we'll refund it right now. You don't need to open PayPal dispute, what is the purpose? You just need to ask for refund, that's it. If a plugin doesn't work, we refund it without any problem.

 
0

The new 1.0.4 version is released, please update it again.

BTW, do you have an empty rows in Blocked IPs textarea?

This post was modified 5 months ago by Tom

Ok, I installed and activated 1.04 and no longer get the errors.  But the behavior of the plugin is a big problem.  Let's say a user has a total of 4 posts.  Then the user makes a fifth post that has an external URL in it.  ALL of that users posts will then get moved to the moderation queue.  The same thing will happen with a banned word.  Also, the "Select an action when uncensored word detected in post" ignore and pending moderation settings behave in exactly the same way.

 

I have no entries in the blocked IPs.

 

I can see a situation where someone has 5,000 posts and then on post 5,001 they post a banned profanity and then all 5,001 posts get moved to the moderation queue.

 

Are these updates actually being tested prior to release?

0

You said all I need to do ask for a refund.  Since this thread has gone cold the plugin is deactivated on my site because of problems...I am asking.  I'll be happy to repurchase when you can give me some reasonable assurance that the plugin actually works.

 
0

Hi @jsaliga,

Sorry for the delayed response. You have nothing to worry, and this issue is not related to the Forums Censure Pro plugin. This is the wpForo antispam system working logic. You'll not have problem with 5000 posts, because this only works for the new registered users. The new registered user level is set in Dashboard > Forums > Tools > Antispam Tab. By default it's set 3. So till the 4th post, new users all posts will be turned to Unapproved if one post become unapproved. But once new users pass the limit of the "new registered user" status, there won't be such problem.

So you can set this level 0, or don't worry at all, knowing that the unapproving process is only working for new registered users.

Another way is disabling the auto-moderation logic, by disabling the wpForo Spam Control option.

In any case, you don't have any problem and there is no any bug in Forums Censure Pro plugin and in wpForo plugin.

wpForo unapproving posts

This post was modified 4 months ago by Tom
 
Share: