embed and attached files issues  

Page 1 / 3

mamamia
Posts: 15
Customer
(@mamamia)
Member
Joined: 2 years ago

Hi, I recently purchased 3-site licenses for file attachment and embeds. I am testing a site [WIP, so I have maintenance mode activated].

----1:
I attached a few images and a file, pasted a YT video URL into a post/reply. Lightbox works. However, it shows not just the files per that post but for the user in the thread all files in all posts!

See: https://www.dropbox.com/s/2qx70z8gps0j1f5/2018-02-10_wpForo-addons-issues_embed-video-size_gallery-showing-all-uploads.mp4?dl=0

How to stop this behavior..? I want lightbox galleries to be relevant per/to every post not to entire user media uploads or forum thread of all posts and attachments!

---2:
And as for YT embed, this should really be a WP supported thing out of the box, not paid because you forbid it and then so expensive.

At least it should work if I buy it.
Video size is a tiny thumb instead of resizing to full space.
In addon settings tab I set it to 0px, tried 0% for auto resize, but all is the same. Tiny miserable thumb in post.

My CF and WP Rocket caching are temporarily deactivated even.
For a good measure, I cleared all CF cache too. To no avail 🙁

---3:

How to insert the attachments in 2 columns all nice and neat as in your addon post example?! Like a gallery.

----4:
Please add basic SEO for images. Need alt tag, title and captions on/off per image one adds, please.

And to be able to MANAGE this for files we upload from frontend. 

Best if can change file slug when uploading, to further SEO things nicely.

Also for lightbox display MUST be able to describe an image with title/ captions!

THX

11 Replies
Tom
Posts: 2931
 Tom
Admin
(@tomson)
Support Team
Joined: 4 years ago

Hi mamamia,

Please find my answers below:

I attached a few images and a file, pasted a YT video URL into a post/reply. Lightbox works. However, it shows not just the files per that post but for the user in the thread all files in all posts!

The Advanced Attachment addon is designed to display all images on this page in lightbox. I'm sorry but there is no way to stop this. We'll take this under consideration and try to add an option in future releases.

And as for YT embed, this should really be a WP supported thing out of the box, not paid because you forbid it and then so expensive.

At least it should work if I buy it.
Video size is a tiny thumb instead of resizing to full space.
In addon settings tab I set it to 0px, tried 0% for auto resize, but all is the same. Tiny miserable thumb in post.

Please note, that wpForo posts are not WordPress post types, they don't support WP post features. The wpForo Embeds addon brings hundreds of embedding options (videos, audios, images, widgets...) this is not a simple YouTube embedding addon. I don't recommend set it 0%. it's better to set it width 100% and height 100%. Then delete all caches and do Ctrl+F5 on forum front.

How to insert the attachments in 2 columns all nice and neat as in your addon post example?! Like a gallery.

First, please navigate to Dashboard > Forums > Settings > Addons > Attachments admin page and set the height of thumbnails to 100px or 150px, It depends on your forum wrapper width. If this doesn't help try to enable the "Thumbnail Box Symmetry" option.

Please add basic SEO for images. Need alt tag, title and captions on/off per image one adds, please.

And to be able to MANAGE this for files we upload from frontend.

Best if can change file slug when uploading, to further SEO things nicely.

Also for lightbox display MUST be able to describe an image with title/ captions!

This is already added. Addon uses file names and put those in alt and title tags. Also it allows you to set custom alt/title when you attach files separatly, you can add it using this syntax in editor (just add it in inserted shortcode):

[ attach title="My Custom Title" ] 2366 [ /attach ]
Reply
mamamia
Posts: 15
Customer
(@mamamia)
Member
Joined: 2 years ago

Hi Tom,

 I don't recommend set it 0%. it's better to set it width 100% and height 100%. Then delete all caches and do Ctrl+F5 on forum front.

Your addon says to set to ZERO. Px or % nothing works.

Also setting to 100% as in your suggestion, clearing all caches, CF on development mode and cleared all its caches for good measure too.

Here's result after Ctrl+F5:

2018 02 11 wpforo issues with embeds
2018 02 11 wpforo issues with video embeds

Reply
Tom
Posts: 2931
 Tom
Admin
(@tomson)
Support Team
Joined: 4 years ago

Please leave your forum URL to allow us check CSS conflicts with your theme.

Reply
mamamia
Posts: 15
Customer
(@mamamia)
Member
Joined: 2 years ago

URL is:  marvelousdesigners.com 

You may create a new user and I'll approve as soon as I see it. We'll be adding content today-tomorrow as the site is finally live. I deleted test garbage content with the vids in post etc.

All in all, I am impressed you have a fast and optimized code here, a page loads really fast and caches clear well as expected. (I wasted lots of time on Sabai Discuss before your plugin and they have great Q&A features but terrible cache issues never clearing).

 

BTW, I set up to enable attaching images from the very 1st posting for new users but it won't let me [in my testing] do so until I had posted 5 times!

2018 02 14 wpforo why need to wait 5 posts to attach files

How to mend this issue?

 

Thank you for fast support!

 

 

 

Reply
Page 1 / 3
Share: