Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum wpForo Support Forum

Adv. attachments stopped working. Images not embeddable, other files corrupt on download (all files corrupt?)


Bjørnar Fjelldal
Posts: 3
Customer
Topic starter
(@bjornarfjelldal)
Member
Joined: 3 years ago

Hi!

This occured a few weeks ago, and I have yet to figure out what is wrong.

No new or previous files uploaded with the advanced attachement plugin works anymore.

They get uploaded, but are corrupt / not embeddable. Images will not be viewed in either the post or in the "Forum Attachment" wp-admin page, and i.e. zip files that are uploaded (or previuosly uploaded) will not unpack. It seems like all files are corrupt in some way.

 

When disabling and uploading natively, everything works, and images uploaded without plugin becomes embedded when activating it.

Tried to delete and re-activate.

Plugin v. 2.1.2. Wordpress 5.9.3

See attached images. Any suggestions?

Skjermbilde 2022 05 04 kl. 13.33.40
Skjermbilde 2022 05 04 kl. 13.36.22
Skjermbilde 2022 05 04 kl. 13.33.44
Skjermbilde 2022 05 04 kl. 13.36.17
2 Replies
Bjørnar Fjelldal
Posts: 3
Customer
Topic starter
(@bjornarfjelldal)
Member
Joined: 3 years ago

Update: It seems like it is the "secure file upload" functionality that breaks it:

Skjermbilde 2022 05 04 kl. 14.03.40

When disabled, everything works. We need this to be enabled.. help?

Reply
1 Reply
Tom
 Tom
Admin
(@tomson)
Joined: 7 years ago

Support Team
Posts: 3819

@bjornarfjelldal,

If you enable this feature, the request to download or show an image goes through PHP files. As far as I see, your website have some security plugin or .htaccess configuration which doesn't allow call PHP files directly. In other words, this is a plugin conflict or your file system is hardened.

You should enable the Secure URLs option and disable other plugins, also you should check the .htaccess file of the root and /wp-content/ directory to make sure it doesn't have any limits for file types.

Reply
Share:
Scroll to top