Comments disappear ...
 
Notifications
Clear all

[Solved] Comments disappear when I choose “sort by…”  

  RSS

jchen2019
(@jchen2019)
Active Member
Joined: 2 months ago
Posts: 5
13/02/2020 1:12 pm  

I want to use the “sort by old/new/most voted” function. If I’m logged in as admin it works properly. But if I’m logged in as a regular user, all comments disappear whenever I change the “sort by” parameters. Any idea why this is happening? Thanks!

Sample link: https://tinyurl.com/r6kutl9 (the website is NSFW)
ID/PW: test/123123


Elvina
(@elvina)
Prominent Member Moderator
Joined: 7 months ago
Posts: 757
13/02/2020 1:19 pm  

Hi @jchen2019,

Please send the admin login details to info[at]gvectors.com email address to allow us to check it.

Also please make sure the plugin editing feature is enabled.


jchen2019
(@jchen2019)
Active Member
Joined: 2 months ago
Posts: 5
13/02/2020 1:46 pm  

OK, email sent, thanks.


Elvina
(@elvina)
Prominent Member Moderator
Joined: 7 months ago
Posts: 757
13/02/2020 3:06 pm  

@jchen2019,

Thank you for details.

The developers just checked your website and saw there is the Remove Dashboard Access plugin that may cause the issue. You should deactivate that plugin and check again. If the issue still exists, please deactivate the plugins one by one to find the problem maker one.

 


jchen2019
(@jchen2019)
Active Member
Joined: 2 months ago
Posts: 5
13/02/2020 3:35 pm  

I've deactivated that plugin but the problem persisted, any idea why?


Elvina
(@elvina)
Prominent Member Moderator
Joined: 7 months ago
Posts: 757
13/02/2020 3:53 pm  

@jchen2019,

It seems one of the active plugins caused the issue. Please deactivate the plugins one by one and check after each deactivation to find a problem maker one, as I already mentioned.

Also please don't forget to delete all caches and press CTRL+F5(twice)  on the frontend each time before checking.


jchen2019
(@jchen2019)
Active Member
Joined: 2 months ago
Posts: 5
13/02/2020 4:27 pm  

I think I found the plugin that's causing it -- "PublishPress Permissions" (previously known as press permit). Just reporting in case someone ran into the same problem. I hope the developers can figure out a fix because I need press permit on my site. Thanks!

Right now I'll just disable the sorting button

This post was modified 2 months ago 2 times by jchen2019

Elvina
(@elvina)
Prominent Member Moderator
Joined: 7 months ago
Posts: 757
13/02/2020 4:57 pm  

@jchen2019,

The issue doesn't have any relation with the wpDiscuz, so it can't be solved by the wpDiscuz side.

You should contact PublishPress PublishPress Permissions plugin and let them know the ajax requests do not work properly with the plugin that caused the problem. So you will need to fix it.

 


jchen2019
(@jchen2019)
Active Member
Joined: 2 months ago
Posts: 5
13/02/2020 4:58 pm  

Got it, thanks


Elvina liked
Share: