Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum wpForo Support Forum

[Closed] Using WP Shortcodes inside Forum Postings


David Taylor
Posts: 8
Customer
Topic starter
(@david-taylor)
Member
Joined: 2 weeks ago

I have about 1,000 spreadsheets that I would like to add into the forum postings.  These are through Supsystic & are shown through Tabs Pro, two separate plugins for WP.  I use the shortcodes from each of these plugins and can input them into the postings.  But, that is not working with WPForo plugin.  I've just purchased three add-ons last night including Embed, Cross Platform, & Custom Field.  I had hoped that Custom Field would have naturally been able to do that; it appears to be a waste of money at this point.  

Can I use the code button above from Custom Field and input some kind of code in order to get the ability to do spreadsheets inside my forum postings?

8 Replies
Tom
Posts: 3752
 Tom
Admin
(@tomson)
Support Team
Joined: 7 years ago

Hi @david-taylor,

Try to put one spreadsheet shortcode in a forum post. It should work if the "Enable WordPress Shortcodes in Post Content" option is enabled in Dashboard > Forums > Settings > Features Tab.

2 Replies
David Taylor
Customer
(@david-taylor)
Joined: 2 weeks ago

Member
Posts: 8

@tomson Thank you for this.  Yes, it works.  But, it does not.  Supsystic just gives me a spinning clock saying it is thinking.  I wonder if there is something with the Supsystic system that does not readily allow it to appear and it gets locked up.  

I have also tried WP Tables.  That works.  But, I have about 1,000 Supsytic tables so, all of a sudden, I'm thinking I may have a lot of work to do.  I'm not in love with WPTables, so I may be looking for yet another version to input into the system.  

Tom
 Tom
Admin
(@tomson)
Joined: 7 years ago

Support Team
Posts: 3752

@david-taylor,

Please leave a direct link to the forum post with the "a spinning clock saying it is thinking".

And leave a URL to a WordPress post where it works. I want to see which HTML tags are stripped in the forum posts. So we could enable them and the issue should be removed.

David Taylor
Posts: 8
Customer
Topic starter
(@david-taylor)
Member
Joined: 2 weeks ago

https://cannabisinvestingnewsletter.com/community/4front-ventures-ffntf-stock-forum-financial-data/4front-ventures-ffntf-stock-revenue/#post-590

Here is my direct link.  There is a .jpeg, WPTables as well as Supsystic.  It would not matter if you did this alone, but all three are present in this posting.  

Thanks for your help; I was not expecting this level of attention.  The forum is great and I like it a lot.  I’d be interested in a bit more functionality and I plan on cruising through the add-ones and seeing if you do some of these things.  

4 Replies
Tom
 Tom
Admin
(@tomson)
Joined: 7 years ago

Support Team
Posts: 3752

Thank you @david-taylor,

But I also asked for a page where it works, for a blog post page or some other page where it works. I need to see what HTML tags it loads on a working page.

David Taylor
Customer
(@david-taylor)
Joined: 2 weeks ago

Member
Posts: 8

@tomson my apologies. Here it works where I am using Tabs Responsive and Supsytic inside that

https://cannabisinvestingnewsletter.com/4front-ffntf-stock/

Tom
 Tom
Admin
(@tomson)
Joined: 7 years ago

Support Team
Posts: 3752

@david-taylor ,

As far as I see, this plugin loads JS code in the post content. Enabling of JS code in the content is not secure.

2021 11 27 13 04 30

In any case, you can try to enable <script> and <style> HTML tags for wpForo posts, it may work... Navigate to Dashboard > Forums > Tools > Antispam Tab, scroll down and find the "Post Content" / "Allow extra HTML tags" section, then put the following line after the already existing content:

, script(), style()
2021 11 27 13 06 12

Save it, delete all caches, then delete wpForo cache in Dashboard > Forums > Dashboard admin page by clicking the [Delete All Caches] button.

Then create a new post with the shortcode. The old ones may not work.

 

As an information, I want to note, that there is no any wpForo addon which is designed for embedding such spreadsheets. This kind of content embeds lots of not-registered HTML tags like <script>, which are filtered for security reasons and cannot be displayed in the post. So I'm really sorry, but if the trick above doesn't help, then you don't have other ways to make it working. You'll not be able to use it in wpForo posts.

David Taylor
Customer
(@david-taylor)
Joined: 2 weeks ago

Member
Posts: 8

@tomson Thank you for this; it did not function.  But, I appreciate the effort you put in.

Share:
Scroll to top