Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum   wpForo Support Forum

[Solved] POST400 error  

  RSS

dooomer
(@dooomer)
Active Member
Joined: 10 months ago
Posts: 19
12/04/2020 12:42 am  

Hello, sometimes I see in Chrome Developer Tools this error:

POST https://mysite.com/wp-admin/admin-ajax.php 400 error

It happens randomly - not for every article open/reload. When I inspect this issue, I can see in Headers this code:

wouAjaxData:

 

{"users":[{"email":"qsieieie@t3teir.pm","name":"loko"},{"email":"jrgu@pragehz.pm","name":"weth"},{"email":"re.re@pragehz.pm","name":"Lolo71"},{"email":"jynffrx@rznvy.pm","name":"Mirko H."}]}
action: wouPushNotification
 
And I found "wouAjaxData" is something to do with WpDiscuz, but I have no idea what is this. I am using native AJAX functions of Wordpress, because custom wpDiscuz AJAX doesn't work with my theme.
 
Do you have any idea how can I fix this? Smile
This topic was modified 4 months ago 2 times by Razmik

Elvina
(@elvina)
Noble Member Moderator
Joined: 12 months ago
Posts: 1235
13/04/2020 4:22 pm  

First of all, please don't worry about this error, it doesn't affect on your site.

Also please note it comes from wpDiscuz Online Users add-on, not from wpDiscuz plugin.
Or maybe your site work overload, that's the reason you get this issue rarely.


dooomer
(@dooomer)
Active Member
Joined: 10 months ago
Posts: 19
14/04/2020 12:10 am  

thanks for reply. And what exactly is causing this in Online Users add-on? Is there any way how to fix this? We have our custom server, so our site can't overload (we checked the server logs) and server usage is about 20 - 30 percent. We are trying to have "good" site with no errors in Chrome Dev Tools, so I hope there is a chance to solve this 🙂


Elvina
(@elvina)
Noble Member Moderator
Joined: 12 months ago
Posts: 1235
14/04/2020 2:42 pm  

@dooomer,

I'm really sorry, but we can't say the exact reason of the issue. The issue is happening when WordPress can't find the action of the ajax, so we can't manage the reason for it. 
We need access to check it on your website, but as you already mention you get the error rarely, so it will be so hard to detect the issue and try to fix it.

 


dooomer
(@dooomer)
Active Member
Joined: 10 months ago
Posts: 19
16/04/2020 10:26 pm  

Hello Elvina, I've checked our server log and this issue is causing so much errors and time-delays for loading page, as you can see on this screenshots:

https://imgur.com/JwflECc

https://imgur.com/UoMkbKj

If you want, I can send you access to our staging site to inspect that issue, but please tell me where, because I don't want to post the credentials here on the forum board Smile


Elvina
(@elvina)
Noble Member Moderator
Joined: 12 months ago
Posts: 1235
17/04/2020 1:30 pm  

@dooomer,

Please send the admin login details to info[at]gvectors.com email address. I'll ask the developers to check it for you.


dooomer
(@dooomer)
Active Member
Joined: 10 months ago
Posts: 19
17/04/2020 6:37 pm  

Thank you. Email sent Smile


Elvina
(@elvina)
Noble Member Moderator
Joined: 12 months ago
Posts: 1235
18/04/2020 2:13 pm  

@dooomer,

The issue is fixed by our developers. 

Please delete all caches, reset all JS minifications, then press CTRL+F5(twice) on the frontend and check. 

 


dooomer
(@dooomer)
Active Member
Joined: 10 months ago
Posts: 19
18/04/2020 3:38 pm  

thank you, I will check it soon. And what changes exactly your developer did on our site? Can you please let me know Smile


Elvina
(@elvina)
Noble Member Moderator
Joined: 12 months ago
Posts: 1235
18/04/2020 3:56 pm  

@dooomer,

There was a small bug in the wpDiscuz Online Users add-on, and it's already fixed by our developers.

 


dooomer liked
dooomer
(@dooomer)
Active Member
Joined: 10 months ago
Posts: 19
19/04/2020 1:19 am  

ok, thanks for letting me know. So you updated the Online plugin to the new version, or you fixed it on your server side? Smile


Astghik
(@astghik)
Support Team Admin
Joined: 3 years ago
Posts: 4341
20/04/2020 1:35 pm  

@dooomer,

The issue is fixed in both cases (in the core of the add-on and on your website). Once we release the add-on you can update it without any worries. The changes made by our developers will not be lost. 


dooomer liked
dooomer
(@dooomer)
Active Member
Joined: 10 months ago
Posts: 19
20/04/2020 2:20 pm  

ok, thanks for reply. And can you please tell me where exactly you did the changes? I need to know for our server admin, because we have no access from WP admin to filesystem on the server Smile so we need to know what (or where) you did the changes Smile


Astghik
(@astghik)
Support Team Admin
Joined: 3 years ago
Posts: 4341
20/04/2020 4:46 pm  

@dooomer,

All changes were done in the /wp-content/plugins/wpdiscuz-online-users/assets/js/wou.js file. 


dooomer
(@dooomer)
Active Member
Joined: 10 months ago
Posts: 19
20/04/2020 5:22 pm  

Amazing, thank you very much Smile


Share: