[Sticky] If Reply button doesn't work  

  RSS

Tom
 Tom
(@tomson)
Support Team Admin
Joined:3 years  ago
Posts: 2603
25/11/2015 3:51 am  

Hi dear wpDiscuz users,
We're getting lots of question regarding to inactive reply button, and in 90% cases the reason is Jatpack Comments plugin. Please note, you can't use two different comment system together. You should keep activated whether wpDiscuz or Jatpack Comments.

When you hit the reply button and nothing happens:
1. Make sure you've deactivated Jatpack Comments
2. Delete all caches and purge CDN

-- If you don't have Jatpack Comments installed

3. Delete all caches and purge CDN

-- If it doesn't help

4. Open Firefox or Chrome console, reload the page and check all JavaScrip Errors. Most of cases you'll find the plugin which cause that error. Just deactivate it and wpDiscuz will work fine.

https://wordpress.org/plugins/wpdiscuz/


ReplyQuote
auludag
(@auludag)
New Member
Joined:2 years  ago
Posts: 1
14/05/2016 2:23 am  

hi, i am using speed booster pack and i discovered that moving to footer your js is well stop this. So i need to do is find the handle for the script for your plugin and i will exclude it from moving to footer. What is the handle name of your plugin script?


ReplyQuote
vsenovilla
(@vsenovilla)
New Member
Joined:2 years  ago
Posts: 1
26/05/2016 2:38 pm  

Morning!

I've just installed the module, and before activating the report addon, I've found the problem I can't see the button Reply on my site.

First of all I read this post and I deactivate all my plugins and it's still not working.

You can see it here:  http://dev.dircomfidencial.com/2016-05-23/noticia/el-principio-de-acuerdo-en-unidad-editorial-mantiene-interrogantes/#comment-1

 

On plugin settings I triple-check the "Hide Reply button for Guests/Members" buttons, and they're disabled. And I can't see any javascript error on chrome console.

Please could you help me solving this?

Thank you in advance


vsenovilla liked
ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined:3 years  ago
Posts: 2603
26/05/2016 11:43 pm  

Hi vsenovilla,

Please read this support topic: http://gvectors.com/forum/how-to-and-troubleshooting/reply-button-not-present/#post-983


vsenovilla liked
ReplyQuote
romanze7
(@romanze7)
New Member
Joined:1 year  ago
Posts: 1
06/04/2017 10:11 am  

Thx u man.

maxbet


ReplyQuote
C.Thorington
(@c-thorington)
New Member
Joined:2 months  ago
Posts: 3
05/04/2018 4:24 pm  

I have purged all caches, but how do I go about purging the CDN?


ReplyQuote
C.Thorington
(@c-thorington)
New Member
Joined:2 months  ago
Posts: 3
05/04/2018 5:03 pm  

The Javascript console for Safari shows an error after I select the "reply" button in wpdiscuz.js. The error is at line 934 in the function replaceUniqueId(uniqueId). The line is:

return secondaryForm.replace(/wpdiscuzuniqueid/g, uniqueId);

and the error message was:

undefined is not an object (evaluating 'secondaryForm.rep

 

Screen Shot 2018 04 05 at 8.48.47 AM


ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined:3 years  ago
Posts: 2603
07/04/2018 2:03 pm  

Hi @c-thorington,

Could you please leave some URL to your website to allow us do a deep debugging. The screenshot says nothing about JS conflicts and the error maker.

Also I recommend deactivate other plugins, keep disabled the cache and activate those one by one and check after each plugin activation. Before checking don't forget to do Ctrl+F5 to reload updated JS/CSS files.


ReplyQuote
EstherButler
(@estherbutler)
New Member
Joined:1 month  ago
Posts: 1
20/04/2018 5:47 pm  

Thanks a lot. Perfectly works for me!


ReplyQuote
Share: