If Reply button doesn't work  

Page 1 / 2
  RSS

Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2913
25/11/2015 3:51 am  

Hi dear wpDiscuz users,
We're getting lots of question regarding to inactive reply button, and in 90% cases the reason is Jatpack Comments plugin. Please note, you can't use two different comment system together. You should keep activated whether wpDiscuz or Jatpack Comments.

When you hit the reply button and nothing happens:
1. Make sure you've deactivated Jatpack Comments
2. Delete all caches and purge CDN

-- If you don't have Jatpack Comments installed

3. Delete all caches and purge CDN

-- If it doesn't help

4. Open Firefox or Chrome console, reload the page and check all JavaScrip Errors. Most of cases you'll find the plugin which cause that error. Just deactivate it and wpDiscuz will work fine.

https://wordpress.org/plugins/wpdiscuz/

This topic was modified 5 months ago by Tom

Quote
auludag
(@auludag)
New Member
Joined: 3 years ago
Posts: 1
14/05/2016 2:23 am  

hi, i am using speed booster pack and i discovered that moving to footer your js is well stop this. So i need to do is find the handle for the script for your plugin and i will exclude it from moving to footer. What is the handle name of your plugin script?


ReplyQuote
vsenovilla
(@vsenovilla)
New Member
Joined: 3 years ago
Posts: 1
26/05/2016 2:38 pm  

Morning!

I've just installed the module, and before activating the report addon, I've found the problem I can't see the button Reply on my site.

First of all I read this post and I deactivate all my plugins and it's still not working.

You can see it here:  http://dev.dircomfidencial.com/2016-05-23/noticia/el-principio-de-acuerdo-en-unidad-editorial-mantiene-interrogantes/#comment-1

 

On plugin settings I triple-check the "Hide Reply button for Guests/Members" buttons, and they're disabled. And I can't see any javascript error on chrome console.

Please could you help me solving this?

Thank you in advance


ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2913
26/05/2016 11:43 pm  

Hi vsenovilla,

Please read this support topic: http://gvectors.com/forum/how-to-and-troubleshooting/reply-button-not-present/#post-983


ReplyQuote
romanze7
(@romanze7)
New Member
Joined: 2 years ago
Posts: 1
06/04/2017 10:11 am  

Thx u man.

maxbet


ReplyQuote
C.Thorington
(@c-thorington)
New Member
Joined: 12 months ago
Posts: 3
05/04/2018 4:24 pm  

I have purged all caches, but how do I go about purging the CDN?


ReplyQuote
C.Thorington
(@c-thorington)
New Member
Joined: 12 months ago
Posts: 3
05/04/2018 5:03 pm  

The Javascript console for Safari shows an error after I select the "reply" button in wpdiscuz.js. The error is at line 934 in the function replaceUniqueId(uniqueId). The line is:

return secondaryForm.replace(/wpdiscuzuniqueid/g, uniqueId);

and the error message was:

undefined is not an object (evaluating 'secondaryForm.rep

 

Screen Shot 2018 04 05 at 8.48.47 AM


ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2913
07/04/2018 2:03 pm  

Hi @c-thorington,

Could you please leave some URL to your website to allow us do a deep debugging. The screenshot says nothing about JS conflicts and the error maker.

Also I recommend deactivate other plugins, keep disabled the cache and activate those one by one and check after each plugin activation. Before checking don't forget to do Ctrl+F5 to reload updated JS/CSS files.


ReplyQuote
EstherButler
(@estherbutler)
New Member
Joined: 11 months ago
Posts: 1
20/04/2018 5:47 pm  

Thanks a lot. Perfectly works for me!


ReplyQuote
SEONGHO SONG
(@gotitkoreagotit-co-kr)
Member Customer
Joined: 7 months ago
Posts: 1
31/08/2018 7:33 pm  

I have purged all caches, but still not active reply button ::
plz check here! https://gotit.co.kr


ReplyQuote
Arina
(@arina)
Trusted Member Moderator
Joined: 5 years ago
Posts: 95
01/09/2018 2:10 pm  

Hi @gotitkoreagotit-co-kr,

We've just tested and have not found such an issue on your website. Could you please specify when exactly this issue happens?

https://gotit.co.kr/archives/4624#comment-104

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.


ReplyQuote
Istquai
(@istquai)
New Member
Joined: 10 months ago
Posts: 4
13/09/2018 5:45 pm  

I have sam problem. Button "Send" doesn't work. Could you check my website? https://erppolska.pl/pozyczki/zylion/


ReplyQuote
Arina
(@arina)
Trusted Member Moderator
Joined: 5 years ago
Posts: 95
13/09/2018 5:48 pm  

Hi @istquai,

Please navigate to Dashboard > Comments > Settings > General admin page, Enable WordPress native ajax option and check again. 

Enable WordPress native ajax

In case you want to say thank you !)
We'd really appreciate and be thankful if you leave a good review on plugin page. This is the best way to say thank you to this project and support team.


Istquai liked
ReplyQuote
Istquai
(@istquai)
New Member
Joined: 10 months ago
Posts: 4
13/09/2018 5:51 pm  
Posted by: Arina

Hi @istquai,

Please navigate to Dashboard > Comments > Settings > General admin page, Enable WordPress native ajax option and check again. 

Enable WordPress native ajax

Thank you. Works!


ReplyQuote
Uri4u
(@uri4u)
New Member
Joined: 4 months ago
Posts: 4
25/11/2018 9:13 pm  

Cache cleared etc. Error messages: 

Site:  https://opiniez.com


ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2913
25/11/2018 11:15 pm  

Hi @uri4u,

Please read the topic main post. It already says what you should check before posting a question.

It says don't use Jetpack Comments with wpDiscuz. You should disable Jetpack Comments and delete all caches.

wpDiscuz Reply button doesnt work
2018 11 25 2314


ReplyQuote
Uri4u
(@uri4u)
New Member
Joined: 4 months ago
Posts: 4
27/11/2018 11:52 pm  

Thanks. Problem solved.


ReplyQuote
redpillersi
(@redpillersi)
Trusted Member
Joined: 1 year ago
Posts: 52
01/03/2019 4:15 am  

Hi, can anyone help with not working buttons for reply, votes etc?

My site: https://swiadomosc-zwiazkow.pl/zmiana-logo-i-grafiki-na-stronie-wazne-ankiety/

 

Problem arrived when i changed few things in w3 total cache and js & css optimizer working together. And i changed my font with CAOS for Webfonts. Now all plugins are deactivated. I have changed themes. I reinstalled last Wordpress update. I enabled native ajax comments in wpdiscuz. I cleared cache. Nothing helps.

Not only buttons don't work but whole style of comments is strange. Small letters, buttons etc.

This post was modified 4 weeks ago 2 times by redpillersi

ReplyQuote
redpillersi
(@redpillersi)
Trusted Member
Joined: 1 year ago
Posts: 52
01/03/2019 4:21 am  

And theme is donovan


ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2913
01/03/2019 2:52 pm  

Hi @redpillersi,

All problems come from W3 Total Cache plugin. It has minified and cached JS and CSS files of wpDiscuz. Now all are loaded incorrectly. Please reset or disable JS/CSS file caching in W3 Total Cache plugin. Then delete all caches then navigate on website front-end press Ctrl+F5 twice to reset browser cache and check it again.

If it doesn't help please disable W3 Total Cache plugin and use WP Super Cache instead.

 

This post was modified 4 weeks ago by Tom

ReplyQuote
Page 1 / 2
Share: