Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum wpForo Support Forum

Comments take about 10 seconds to post


daviddietz
(@daviddietz)
New Member
Joined: 3 years ago
Posts: 4
Topic starter  

When users comment, they click the "Post comment" button, but it's taking about 10 seconds to post the comment, so they think it's not posting.

1. Is there a fix for this issue (could it be in the settings somewhere... something I'm missing)?
2. Can you create a toggle for the "Post comment" button so that it becomes disabled after clicking it and changes the value of the button to, "Please wait..." or something along those lines?


Quote
Topic Tags
Astghik
(@astgh)
Support Team Admin
Joined: 4 years ago
Posts: 5007
 

Hi daviddietz,

Could you please leave your website URL to allow us to check it?


ReplyQuote
daviddietz
(@daviddietz)
New Member
Joined: 3 years ago
Posts: 4
Topic starter  

You bet. https://allthenourishingthings.com/


ReplyQuote
Astghik
(@astgh)
Support Team Admin
Joined: 4 years ago
Posts: 5007
 

Hi @daviddietz,

Please navigate to Dashboard > Comments > Settings >General admin page, Enable "Use WordPress native AJAX functions" and chack again. 

As far as I see you've done a customization that's why we couldn't guess what gonna wrong on your website. 


ReplyQuote
daviddietz
(@daviddietz)
New Member
Joined: 3 years ago
Posts: 4
Topic starter  
Thanks. That's been enabled. The only customization I've made is to the submit button. 


<input id="commentSubmit" class="wc_comm_submit wc_not_clicked button alt" type="submit" onclick="this.value='Please wait...';" onmouseup="changeCursor();" name="<?php echo $name; ?>" value="<?php echo $args['name']; ?>">
<script>
function changeCursor() {
document.getElementById("commentSubmit").style.cursor = "not-allowed";
}
</script>

ReplyQuote
daviddietz
(@daviddietz)
New Member
Joined: 3 years ago
Posts: 4
Topic starter  

I'll add that the delay still occurs with or without that customization.


ReplyQuote
Share:
Scroll to top