[Sticky] wpDiscuz subscription and email notification don't work  

Page 2 / 2 Prev
  RSS

Scott
Active Member Customer
Joined:9 months  ago
Posts: 9
22/03/2017 8:51 pm  

So all replies to comments need to be done on the frontend? This is not user-friendly for the admin who gets 20+ comments a day. Hopefully, this is added soon. I also did not see this explained anywhere that you had to do it in the frontend. Maybe I missed it.


ReplyQuote
Tom
 Tom
Support Team Admin
Joined:2 years  ago
Posts: 2006
22/03/2017 8:55 pm  
Posted by: Scott

So all replies to comments need to be done on the frontend? This is not user-friendly for the admin who gets 20+ comments a day. Hopefully, this is added soon. I also did not see this explained anywhere that you had to do it in the frontend. Maybe I missed it.

This may be done by Wordpress, please navigate to Dashboard > Settings > Discussions admin page and make sure the Notify by Email options are turned on.

wpDiscuz Documentation


ReplyQuote
siahtirim
New Member
Joined:6 months  ago
Posts: 1
12/04/2017 12:20 am  

Hi

unfortunately I have this problem too

I've found that when I, admin, reply a guest's comment in the dashboard, the notification email won't send. But, when I reply him in the comment area on the post, the notification email will send.

so what is the solution for that?

we shall wait for next update?

or it would be like this forever 

 


ReplyQuote
Dano
 Dano
New Member
Joined:5 months  ago
Posts: 1
19/05/2017 9:06 am  

I am having the same problems - have gone through the steps but my server is sending emails fine and the table is all OK.

Is this simply a bug with the plugin?

Can you recommend another plugin to help ensure email notifications as these are important - we have a membership site and since this stopped working it's causing a lot of grief.

Are there any settings we could possibly have wrong - we looked through them but didn't see anything that woudl suggest that notifications shouldn't be emailed.

Thanks for your help.


ReplyQuote
Tom
 Tom
Support Team Admin
Joined:2 years  ago
Posts: 2006
19/05/2017 8:27 pm  

This plugin is used, approved and tested on dozens of thousands website. wpDiscuz doesn't have any bug related to email sender functions. As it's already described in this topic it may depend on lots of other things. Except of all mentioned points you can disable all other plugins and test it, this may be a simple plugin conflict.

I'm sorry but site specific email issues have no chance to be debugged and helped by our support team. We've mentioned all possible cases, website admins should find the solution themselves.

Edited: 3 months  ago

wpDiscuz Documentation


ReplyQuote
controvi
Active Member
Joined:1 year  ago
Posts: 6
20/07/2017 11:28 am  

I know this might fall into exactly what you said in your message but thought this might be a bit special in that it is really weird how the plugin is sending mail.

The issue being that I can post a comment on a post and check that I want to be notified of replies.

I get the mail with the subcribe confirmation link, I get the mail notifying the author of a reply and the admin gets an email about moderating the comment.

But as soon as I confirm my subscription and than with another email reply on the first comment the author and admin get their mails the commenter gets the subscription email but the first comment author gets nothing.
and that continues.

For some reason everything works up till the subscription confirmation email and than it stops.
No emails about replies what so ever.

Do you have any idea where I need to look to find out why this happens ?
I am pretty sure that it has to be something in wordpress that is set up wrong but don't know what.

note: I have a smtp mail logging plugin looking at all outgoing email and there is see the email notifications to the admin and author of the post going out but there is no email send to the commenter what so ever.

I would have thought if something was not working in the sending department of the plugin it wouldn't send emails at all.

Hope you can give me some pointers to where I should look.
And if you can't say anything about the issue as it can have so many things going wrong than that is ok.
If I don't ask I would by fact not get any answer.

Cheers.


ReplyQuote
controvi
Active Member
Joined:1 year  ago
Posts: 6
20/07/2017 11:40 am  

I want to add to my last post that it also doesn't put anything in the database.
the subscription table is completely empty


ReplyQuote
Tom
 Tom
Support Team Admin
Joined:2 years  ago
Posts: 2006
20/07/2017 6:42 pm  

Could you please disable all plugins related to email? If it doesn't help, try to disable all plugins. Make sure the email is set with your website domain (admin@example.com) in Dashboard > Settings > General admin page.

wpDiscuz Documentation


ReplyQuote
controvi
Active Member
Joined:1 year  ago
Posts: 6
21/07/2017 11:48 am  

Thank you for the comment.
I currently have found out what part of the issue was.
Your plugin isn't sending the correct confirmation key to the commenter when it replies on a reply on its own comment.

to illustrate.

- I comment on a post and subscribe and confirm through the email.
- someone else replies to that comment.
- I get the reply notification.
- than I reply to the reply and select subscribe again. (hold on with any comments here about subscrubing again)
- I get the email for confirming my subscription and confirm.
- then the other guy replies back at me and I get no email notification.

When I found was that as soon as I click subscribe again on my reply to another reply on my comment it sends the first subscription key in the email and not the new entry in the database.

I saw in the database that there is a new entry created but the key of the first subscription is send though that one is already actived.

I also tried not to subscribe to the post but that also doesn't get me notification email.

So basically as long as I don't get replies more than 1 deep I'm good but if it goes deeper than it fails.


ReplyQuote
controvi
Active Member
Joined:1 year  ago
Posts: 6
25/07/2017 4:12 pm  

Any update on my issue in the above post


ReplyQuote
Tom
 Tom
Support Team Admin
Joined:2 years  ago
Posts: 2006
26/07/2017 8:39 am  

We found the issue and fixed. Please wait for the next wpDiscuz version release.

wpDiscuz Documentation


ReplyQuote
controvi
Active Member
Joined:1 year  ago
Posts: 6
26/07/2017 10:54 am  

Cool 🙂
Glad I could help


ReplyQuote
controvi
Active Member
Joined:1 year  ago
Posts: 6
21/08/2017 2:28 pm  

Hey guys,
Here I am again.

It seems that the issue is not solved even after the update.
I am guessing you might have solved it partially though.

The thing I am noticing right now is that when I already have a subscription in my database for 1 blogpost it won't send me the correct subscription key and instead sends me an old one that was already activated.

So I think that whenever you have the article "example" and someone sends in a comment, the first comment will work with the subscription but commenting on another reply will break it.
Also commenting on the blog post a second time won't work.

Hope this can help with solving the issue.

Cheers


ReplyQuote
Tom
 Tom
Support Team Admin
Joined:2 years  ago
Posts: 2006
21/08/2017 7:06 pm  

It works well, we've made tests before releasing. I think it's depends on your old data I recommend register a new user and do the same test.

wpDiscuz Documentation


ReplyQuote
Page 2 / 2 Prev
  
Working

Please Login or Register