Avatar not changing  

  RSS

mathieufd
(@mathieufd)
Active Member
Joined: 2 months ago
Posts: 10
11/02/2019 4:00 pm  

When I change my avatar (ultimate or other plugin), the avatar stays the same in comment, even if I add a new comment.? I disabled cache from your menu. Very weird


Quote
mathieufd
(@mathieufd)
Active Member
Joined: 2 months ago
Posts: 10
11/02/2019 4:29 pm  

The avatar is ok is in the input (no avatar), but when i post a comment, the avatar stays as the old one (green avatar). Even if I put a new avatar, it doesn't work. Avatar is ok everywhere (dashboard, profile...) except in your comment plugin

Capture d’écran 2019 02 11 à 13.27.39


ReplyQuote
mathieufd
(@mathieufd)
Active Member
Joined: 2 months ago
Posts: 10
11/02/2019 5:01 pm  

I figured that the plugin has weird behaviour and this is causing all my problems :

- When you visit a post with comments, it will "cache" the username/avatar/label

- When you visit another post, it will load the username/avatar/label from the first post comment you read.

So, if the avatar not changing is not a big deal, the "label" problem a is serious one. Let's take an example: UserA writes a comment in is own postX. The label for the userA will be "Author" in this specific post. But, then you read a postY where UserA wrote a comment where he is NOT the post author, then his label will stay as "Author" and not as "user" or "member" or whatever else. 

Then, clean your browser (cookies etc.). Go firstly on postY (where userA is NOT the post author), his label will be correct: Member

Go to postX (where userA is the post author), his label be INCORRECT: member. It should be "Author". 

I think it's a major issue with the plugin. I tried the plugin with different installations, local and live, without native theme and no plugin activated and it's all the time the same thing.

I really want to buy the plugin because i need the flag and mention fonctionality. But now I don't know because of this problem. What can cause this?


ReplyQuote
mathieufd
(@mathieufd)
Active Member
Joined: 2 months ago
Posts: 10
11/02/2019 5:21 pm  

This is what I mean: (it's a fresh installation, no plugin activated, native Nineteen wp theme)

1) I visited Nathalie's post where she commented. She is labeled as "Author" = CORRECT

Capture d’écran 2019 02 11 à 14.15.39

2) Then, I visited Mathieu's post where Nathalie commented. She is labeled as "Author" = NOT CORRECT

Capture d’écran 2019 02 11 à 14.15.54

3) I cleared my browser (went to inconito mode / Clear cookies). I firstly visited Mathieu's post. She is labeled as "Member" = CORRECT

Capture d’écran 2019 02 11 à 14.13.35

And it's always the same thing. What's going on? 

Thank you and sorry for the long post, just wanted to be clearer as possible

 


ReplyQuote
Astghik
(@astghik)
Support Team Admin
Joined: 1 year ago
Posts: 2254
12/02/2019 2:28 pm  

Hi @mathieufd,

Please follow these steps to get it resolved: 

  • Download the class.WpdiscuzWalker.zip
  • Copy the file class.WpdiscuzWalker.php  file from this folder
  • Replace the class.WpdiscuzWalker.php file in /wp-content/plugins/wpdiscuz/templates/comment folder with a file from class.WpdiscuzWalker.zip

 

This post was modified 2 months ago by Astghik

ReplyQuote
Share: