full width forum
 
Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum wpForo Support Forum

[Solved] full width forum

7 Posts
2 Users
0 Likes
4,043 Views
Joon Choi
(@juliam0m)
Member Customer
Joined: 6 years ago
Posts: 23
Topic starter  

I would like to the forum to be full width and no sidebar.  how do I do this?  the template is already in default template (full width) and no sidebars are selected from the page, but the side bar is still there.   


   
Quote
Joon Choi
(@juliam0m)
Member Customer
Joined: 6 years ago
Posts: 23
Topic starter  

I'm assuming that show/hide of forum sidebar is determined by is_active_sidebar value.  where is this coming from?  

I don't have any of the sidebars selected. yet forum sidebar is showing.  the template for the page is set to default, which with the theme i'm using is the full width template.


   
ReplyQuote
Joon Choi
(@juliam0m)
Member Customer
Joined: 6 years ago
Posts: 23
Topic starter  

for now, I used the css to do this, but it would be nice to have the option to turn it on and off in the settings in the future release.

 


   
ReplyQuote
Tom
 Tom
(@tomson)
Famed Member Admin
Joined: 8 years ago
Posts: 3994
 

wpForo cannot have an option for this. This comes from your theme Page Templates. If your theme has a full width template you can set it, if not you should use visual composers or something like that. wpForo has no chance to affect your theme page templates.


   
ReplyQuote
Joon Choi
(@juliam0m)
Member Customer
Joined: 6 years ago
Posts: 23
Topic starter  

my theme does have default template which is full width.  and the wpforo page is set to that template.  and I have not set any sidebar to go with it, yet I still have wpforo sidebar showing.  but that's ok.  


   
ReplyQuote
Tom
 Tom
(@tomson)
Famed Member Admin
Joined: 8 years ago
Posts: 3994
 

It's sidebar cache. You should add some widget in wpForo sidebar, save it, then delete it again. This will reset sidebar cache and you'll get full width. That's it.


   
ReplyQuote
Joon Choi
(@juliam0m)
Member Customer
Joined: 6 years ago
Posts: 23
Topic starter  

it worked! thank you~


   
ReplyQuote
Share:
Scroll to top