Guest can't vote a comment  

  RSS

leonir
New Member
Joined:10 months  ago
Posts: 1
20/12/2016 3:38 pm  

It's the logged out state. A guest can comment but not vote. 

The logged in user can vote to himself, to others, not twice, as should be.

In short: it should allow guests to vote


ReplyQuote
Tom
 Tom
Support Team Admin
Joined:2 years  ago
Posts: 2006
20/12/2016 8:38 pm  

Please use "Allow guests to vote on comments" option in Dashboard > Comments > Settings admin page:

wpDiscuz Documentation


ReplyQuote
Wolfneo
Active Member
Joined:8 months  ago
Posts: 5
20/02/2017 2:44 pm  

Hi,

I checked it in "Dashboard> Comments> Settings admin page" line and yet it does not work.
I still have the error message "You are not allowed to vote for this how"

On the wp.org forum, you say in a message

"Navigate to Dashboard> Comments> Forms admin page, edit Default Form and check it."

But I do not see the option there, or the screenshot, do you have a screenshot for the watch?
Thank you

http://hpics.li/12218f2
and
http://hpics.li/a8d60b0

Edited: 8 months  ago

ReplyQuote
Tom
 Tom
Support Team Admin
Joined:2 years  ago
Posts: 2006
20/02/2017 11:40 pm  

Could you please leave website URL? We can't support you without debugging website JS functions.

wpDiscuz Documentation


ReplyQuote
Wolfneo
Active Member
Joined:8 months  ago
Posts: 5
21/02/2017 1:11 pm  

Hi,

Here is the address of my site
https://logganeo.fr/

You answered me there
https://wordpress.org/support/topic/allow-guests-to-vote-on-comments-checked/

Your last post was

This option is located in Form settings in wpDiscuz 4. Make sure you’ve checked it in correct place. Navigate to Dashboard > Comments > Forms admin page, edit Default Form and check it.

I do not see the option in Default Form.
How are you debugging the js functions of my site? 

I have the plugin WP Roket

Thank You


ReplyQuote
Tom
 Tom
Support Team Admin
Joined:2 years  ago
Posts: 2006
22/02/2017 1:44 am  

Please disable JS optimization of WP Roket.

Then make sure this option is enabled. Delete cache and do Ctrl+F5 on post.

wpDiscuz Documentation


ReplyQuote
Wolfneo
Active Member
Joined:8 months  ago
Posts: 5
22/02/2017 1:37 pm  

Hi,

If this works, does that mean I have to keep JS optimization turned off?

That does not help me, I want the js to be optimized to lighten my site.

 

I put a screeshot in my previous posts, you see that the option is checked, I am French, so the sentence is in French.

I just do what you say and the whole message "You are not allowed to vote for this comment"

 

Do you need chmods 644 and 755?

In the database, the structure of the tables are how? What options?

Thank you

Edited: 8 months  ago

ReplyQuote
Tom
 Tom
Support Team Admin
Joined:2 years  ago
Posts: 2006
22/02/2017 2:33 pm  

I just voted and it works fine. Make sure you vote one time for the same comment. It checks your IP and cookies and doesn't allow to vote/like twice.

Video: https://www.screencast.com/t/AgsH5mcM

wpDiscuz Documentation


ReplyQuote
Wolfneo
Active Member
Joined:8 months  ago
Posts: 5
22/02/2017 2:39 pm  

Hi,

How do I check if it works then? If it checks the IP?

 

I vote on all comments of course, I wanted to make sure that it works for the visitors too.
Thank you


ReplyQuote
Tom
 Tom
Support Team Admin
Joined:2 years  ago
Posts: 2006
23/02/2017 2:21 am  

Ask your friends to vote or something else. I don't know, I see it works fine.

wpDiscuz Documentation


ReplyQuote
Wolfneo
Active Member
Joined:8 months  ago
Posts: 5
23/02/2017 1:02 pm  

I thought the admin was not constrained the IP and the cookies to vote.

It would be necessary to exclude admins from these rules

Subject resolved.


ReplyQuote
  
Working

Please Login or Register