Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum ย  wpForo Support Forum

[Solved] reCAPTCHA Version 2 works partially  


Laurent
Posts: 22
Customer
(@laurent)
Member
Joined: 2 years ago

Hello,

If I enable "reCAPTCHA Version 2" for "Guest" comments, it work on in the "Comment subscriptions section" but not in the "posting of a comment".

Strangely, if reCAPTCHA Version 2 is enabled for "Guest" comments, it is still possible to post a comment while reCAPTCHA Version 2 is not displayed.
On the other hand, if I try to reply to a comment, reCAPTCHA Version 2 is still not displayed and I get an error message.

Sorry for my bad English language, I hope you understand what I write :/

ScreenShot00835
13 Replies
Laurent
Posts: 22
Customer
(@laurent)
Member
Joined: 2 years ago

I just reactivated the function, I turned it off just before your test.

ย 

Reply
1 Reply
Taron
Moderator
(@taron)
Joined: 4 years ago

Active Member
Posts: 10

@laurent

Please clear the WP Rocket cache and test again.

Reply
Laurent
Posts: 22
Customer
(@laurent)
Member
Joined: 2 years ago

Same.

ScreenShot00836
ScreenShot00837
Reply
3 Replies
Tom
 Tom
Admin
(@tomson)
Joined: 5 years ago

Support Team
Posts: 3220

@laurent,

This requires deeper debugging. Could you please send admin login details to info[at]gvectors.com email address?

Reply
Laurent
Customer
(@laurent)
Joined: 2 years ago

Member
Posts: 22

@tomson

Sent ๐Ÿ˜‰

Reply
Tom
 Tom
Admin
(@tomson)
Joined: 5 years ago

Support Team
Posts: 3220

Thank you @laurent.

Reply
Tom
Posts: 3220
 Tom
Admin
(@tomson)
Support Team
Joined: 5 years ago

Hi @laurent,

This issue is fixed. You were using two antispam solutions for comment form. Currently, you're using WPBruiser antispam plugin, so we've added a small code to stop reCAPTCHA if the WPBruiser is enabled. If you want to use reCAPTCHA you should disable the WPBruiserย  plugin.

Update:

Ok, we disabled WPBruiser option for comments end enabled reCAPTCHA. Now all works fine.

Reply
6 Replies
Laurent
Customer
(@laurent)
Joined: 2 years ago

Member
Posts: 22

@tomson

 

Oh, did I waste your time because of WPBruiser? ๐Ÿ™

Reply
Tom
 Tom
Admin
(@tomson)
Joined: 5 years ago

Support Team
Posts: 3220

@laurent,

No problem, we'll add this change in the core. There are many WPBruiser users, it'll be good for all.

Reply
Laurent
Customer
(@laurent)
Joined: 2 years ago

Member
Posts: 22

@tomson

Ok, many thanks for your time and great work.
Do you have a Paypal link for a little donation ?

If you need others Admin test, for others customers, don't hesitate to contact me ๐Ÿ˜‰

Thank you very much.

Reply
Tom
 Tom
Admin
(@tomson)
Joined: 5 years ago

Support Team
Posts: 3220

Hi @laurent,

A good review in wpDiscuz plugin page will be the best donation for us.

Thank you very much!

Reply
Laurent
Customer
(@laurent)
Joined: 2 years ago

Member
Posts: 22

@tomson

It's done. Alas, I couldn't put more than five stars ๐Ÿ˜€

 

Reply
Tom
 Tom
Admin
(@tomson)
Joined: 5 years ago

Support Team
Posts: 3220

@laurent,

Nice! Thank you very much, we greatly appreciate it!

Reply
Share: