Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum   wpForo Support Forum

[Solved] How can I completely remove the E-Mail field?  

  RSS

a5c
 a5c
(@a5c)
New Member
Joined: 9 months ago
Posts: 2
15/10/2019 11:23 am  

I want to have only one field and the comment text edit.

In this case I need just a username and comment, nothing else.

I hope you can help me out with my problem.

Thanks in advance.

Best Regards


Topic Tags
Elvina
(@elvina)
Noble Member Moderator
Joined: 10 months ago
Posts: 1177
15/10/2019 1:00 pm  

Hi @a5c,

Thank you for using wpDiscuz.

Please follow the steps below to get it resolved:

1. Navigate to Dashboard > Comments > Forms admin page, edit the "Default form". In Comment Form Builder section, find and edit the email field, then uncheck the "Field is required" checkbox. More info here: https://wpdiscuz.com/docs/wpdiscuz-documentation/getting-started/custom-comment-form/comment-form-builder/#comment_form_fields

2. Navigate to Dashboard > Comments > Settings > Styling admin page, put the following CSS code in the "Custom CSS Code" textarea:

#wpcomm .wpd-form-row .wpdiscuz-item input[type="email"]{
display:none !important;
}

Don't forget to delete all caches before checking.


a5c liked
a5c
 a5c
(@a5c)
New Member
Joined: 9 months ago
Posts: 2
15/10/2019 1:04 pm  

Thank you, When I set unchecked required, the field still showed up, I managed to remove it by editing the css files.


Share: