Notifications
Clear all

Paid Addons Support Forum Only

Please note, that here we only support Paid Addons issues and questions.

gVectors Support staff works from 6am to 6pm (GMT+0)

All questions related to wpForo and wpDiscuz free plugins should be asked in the corresponding plugin support forum:

 

wpDiscuz Support Forum   wpForo Support Forum

WP Discuzz Report and Flag addon  


Alfonso González
Posts: 10
Customer
(@alfonso-gonzalez)
Member
Joined: 8 months ago

Hi,

 

I've purchased this addon and i would like replace flag icon with a text: "Reportar"

How i can do it? And i would like to display after my botton link to "respond".

I've attached a screenshot to explain new location from link that i wanted.

Sin título

 

 

Thanks!

7 Replies
Elvina
Posts: 1050
Moderator
(@elvina)
Noble Member
Joined: 9 months ago

Hi @alfonso-gonzalez,

Thank you for using wpDiscuz Comment Report and Flagging add-on.

Please follow the steps below to get it resolved:

1. Navigate to Dashboard > Comments > Settings > Styling admin page, put the following CSS code in the "Custom CSS Code" textarea.

#wpcomm i.fa-flag:before {
display: none;
}

2. Add the js codes below in your active theme's js files:
2.1 The following js code replaces the icon to a "Report" text:

jQuery('.comment_flag.comment_flag_modal.wc_flag_tooltipster.wpf-cta.wpd-field-desc i').text('Report');

2.2 The following js code changes the position of the "Report" button:

jQuery.each(jQuery('.comment_flag'), function () {
jQuery(this).insertAfter(jQuery(this).parents('.wc-comment-right').find('.wc-footer-left .wc-reply-button'));
});

After those changes, you'll get some CSS conflicts. The conflicts you should solve manually.

Below is the selector you should use:

.fas.fa-flag{/* here should be added your custom CSS rules */}

For example if you'd like to remove the background-color you should use the following code:

.fas.fa-flag{
background-color: #fff !important;
}

All CSS codes should be added in the "Custom CSS Code" textarea. Don't forget to delete all caches before checking.

Reply
Alfonso González
Posts: 10
Customer
(@alfonso-gonzalez)
Member
Joined: 8 months ago

Hi there,

 

Thanks so much, now is working perfect.

 

So i have a new question, im trying to add social login but im disabled

https://desa2.fundaciontransparenciayopinion.org/wp-admin/admin-ajax.php?action=wpd_login_callback&provider=facebook

My login page is https://desa2.fundaciontransparenciayopinion.org/login

so, how i can change it?

Reply
1 Reply
Elvina
Moderator
(@elvina)
Joined: 9 months ago

Noble Member
Posts: 1050

@alfonso-gonzalez

I'm sorry, but I don't follow you. Please try to explain using some screenshots.

Reply
Alfonso González
Posts: 10
Customer
(@alfonso-gonzalez)
Member
Joined: 8 months ago

Sorry, mi english is very poor. I will try to explain better.

Im protected my /wp-admin directory, my login page is https://desa2.fundaciontransparenciayopinion.org/login

When you try to go to https://desa2.fundaciontransparenciayopinion.org/ wp-admin it redirects to https://desa2.fundaciontransparenciayopinion.org/login

 

So, to activate facebook login, in your plugin screen instructions appears this text:

Valid OAuth Redirect URI :  https://desa2.fundaciontransparenciayopinion.org/wp-admin/admin-ajax.php?action=wpd_login_callback&provider=facebook

this is not valid for me because wp-admin is redirecting to /login no? I need change Oauth Redirect URI?

 

 

Reply
3 Replies
Elvina
Moderator
(@elvina)
Joined: 9 months ago

Noble Member
Posts: 1050

@alfonso-gonzalez,

I'll ask wpDiscuz developers, and let you know as soon as possible.

 

Reply
Alfonso González
Customer
(@alfonso-gonzalez)
Joined: 8 months ago

Member
Posts: 10

@elvina

OK thanks, i will waiting for a solution

Reply
Elvina
Moderator
(@elvina)
Joined: 9 months ago

Noble Member
Posts: 1050

@alfonso-gonzalez,

Please try to add the following URL in "Valid OAuth Redirect URL" section:

https://desa2.fundaciontransparenciayopinion.org/login/admin-ajax.php?action=wpd_login_callback&provider=facebook

We've just changed the "wp-admin" to "login" in the URL.

Don't forget to delete all caches before checking.

 

 

 

Reply
Share: