[Solved] Media Uploader  


joschott
Posts: 5
Customer
(@joschott)
Member
Joined: 4 months ago

Hello Suopport team, 

I did buy the Media Uploader AddIn last week. 

It looks like it does not work. While all controls appear and I can select a picture, the Upload seems to fail. The respective comment is posted but the picture is not. The loading indicator is permanently bouncing until next site reload. Did I miss a setting?

 

Jo

11 Replies
Astghik
Posts: 2633
Admin
(@astghik)
Support Team
Joined: 2 years ago

Hi @joschott,

Please leave some example URL to allow us to check it. 

2 Replies
joschott
Customer
(@joschott)
Joined: 4 months ago

Member
Posts: 5

https://www.schott-baerenwalde.de/  

 

you will need to register....

joschott
Customer
(@joschott)
Joined: 4 months ago

Member
Posts: 5

looks like it did work for you - thats strange

 

Astghik
Posts: 2633
Admin
(@astghik)
Support Team
Joined: 2 years ago

yes @joschott, it's working fine in our case. Could you please tell me a little more about what’s going on? where exactly are you running into the error?

I'd recommend you delete all website caches and browser cache (CTRL+F5 twice) and check again. 

 
 
 
2 Replies
joschott
Customer
(@joschott)
Joined: 4 months ago

Member
Posts: 5

It did work when I downloaded your banner pic but not for one of mine  - let me check file size etc...

joschott
Customer
(@joschott)
Joined: 4 months ago

Member
Posts: 5

I did test with your picture several times  - it just works fine. 

All test with my pictures failed. After clicking the "Post" button nothing happens and the little dot at the top keeps bouncing forever. 
Tested with Safari and Chrome on Mac and iPhone

File Types png and jpg

File Size 85kb -1.7MB max 1024 x1024px or smaller

Astghik
Posts: 2633
Admin
(@astghik)
Support Team
Joined: 2 years ago

@joschott,

you should try to increase the maximum upload file size in WordPress. This article should be helpful for you, please check it out:  https://www.bitcatcha.com/blog/increase-maximum-upload-file-size-in-wordpress/

4 Replies
willyschott
(@willyschott)
Joined: 4 months ago

New Member
Posts: 3

Hello, may I chime in on the topic.

I was able to hunt the issue down by a local installation of Wordpress (official docker image). The problem is not lack of memory, but a missing PHP extension, and no test exists to catch it. Suggestion for a fix:

Index: wpdiscuz-media-uploader/includes/class.WMUHelper.php
<+>UTF-8
===================================================================
--- wpdiscuz-media-uploader/includes/class.WMUHelper.php	(date 1551308602000)
+++ wpdiscuz-media-uploader/includes/class.WMUHelper.php	(date 1551308602000)
@@ -458,6 +458,9 @@
     }
 
     public function imageFixOrientation($filename) {
+        if (!function_exists('exif_read_data')) {
+            return;
+        }
         $exif = exif_read_data($filename);
         if (!empty($exif['Orientation'])) {
             $image = imagecreatefromjpeg($filename);
willyschott
(@willyschott)
Joined: 4 months ago

New Member
Posts: 3

*bump*

Any intention to incorporate this bugfix?

Astghik
Admin
(@astghik)
Joined: 2 years ago

Support Team
Posts: 2633

Hi @willyschott,

We've already added the changes in the addon core. The change will be included in the next version release. Please wait for the next update (no ETA yet). 

willyschott
(@willyschott)
Joined: 4 months ago

New Member
Posts: 3

Hi @Astghik,

OK, thanks for the update!

Share: