wpDiscuz Social Login works, however requires manual page reload  

  RSS

markus
(@markus)
New Member
Joined:3 months  ago
Posts: 3
02/06/2018 6:11 pm  

Hi,

first, thanks for the awesome plugin! I replaced Facebook comments with wpDiscuz and it works really well despite one issue. When I use one of the login buttons, either Facebook or Google (btw miss Instagram, any chance to include this?), I am actually logged in, the comment form still says, that I am not. I need a page reload in my browser, then the status is shown right - but no user will grasp that :/

Here is a test page:  https://lustwandler.at/2000/01/01/test_comments/

I would deeply appreciate any hints!


ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined:3 years  ago
Posts: 2735
03/06/2018 11:24 pm  

Hi markus,

This is a website specific issue and we don't have any chance to debug it and find the reason. The only way is disabling all plugins, deleting all caches and testing it again. The you should enable those one by one and find the conflict maker plugin. After testing this with disabled plugins, you should change current active theme and use one of the default WordPress plugins.


ReplyQuote
markus
(@markus)
New Member
Joined:3 months  ago
Posts: 3
11/06/2018 10:54 pm  

Hi Tom,

been there, done that. Even with all plugins disabled and the theme reset to the wordpress default the site the login shows exactly the same behaviour. 

Any other things I could check for?

Maybe a problem with the configuration on FB oder Google? Is the Valid OAuth Redirect URIs really just https://lustwandler.at (or https://www.lustwandler.at) without any path?


ReplyQuote
Tom
 Tom
(@tomson)
Support Team Admin
Joined:3 years  ago
Posts: 2735
14/06/2018 12:37 pm  

Do you have any restriction for cookies? As far as i see the cookies are not set and website cannot authorize (login) user in first load. Some caching function or cookie restriction affects user loagin process.

Maybe a problem with the configuration on FB oder Google? Is the Valid OAuth Redirect URIs really just https://lustwandler.at (or https://www.lustwandler.at) without any path?

Yes, maybe. The valid URL is https://lustwandler.at . Also try the ajax file URL:

 https://lustwandler.at/wp-admin/admin-ajax.php 

ReplyQuote
markus
(@markus)
New Member
Joined:3 months  ago
Posts: 3
22/07/2018 3:27 pm  

I have been successful now with the URL that you now display in the plugin settings (you seem to have added this in some update, I do not remember this line from before): https://lustwandler.at/wp-admin/admin-ajax.php?action=wpd_login_callback&provider=facebook

However, the problem is still there with Google, unchanged, neither  https://lustwandler.at  (as proposed in the plugin settings) nor  https://lustwandler.at/wp-admin/admin-ajax.php make a difference.

 


ReplyQuote
Share: