Sharing icon has disappeared  

  RSS

phinx1
(@phinx1)
Active Member
Joined: 1 month ago
Posts: 7
15/05/2019 10:16 am  

When I first installed wpDiscuz, there was a sharing icon in the upper right corner of a posted comment, beside the link icon for copying the URL of a comment. After having to deactivate than re-activate the plugin for some debugging, the sharing icon is now gone and there is only the icon for copying the comment's URL to clipboard.

I've run through the settings tabs repeatedly and can't find how to re-enable the sharing icon. Appreciate your help with this, thanks!


Quote
Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 2631
15/05/2019 12:00 pm  

Hi @phinx1,

If I understand you correctly the Social Sharing icons are enabled form Dashboard > Comments > Settings > Social Login & Share tab and they don't appear on the frontend, do they?  

Please make sure you've deleted all caches before checking. 

Enable Share Button


ReplyQuote
phinx1
(@phinx1)
Active Member
Joined: 1 month ago
Posts: 7
15/05/2019 10:41 pm  

Yes, that was what I needed to do, thank you! However, after I checked the share boxes for Facebook and Twitter, the sharing icon now shows but only the Twitter icon appears when I hover my cursor over it. Do I need to do something else to get the Facebook icon to show too?

One other question, when I paste the URL for an image then post the comment, it shows just a blank area where the graphic should be. After I refresh the page, it is visible. A similar issue happens with existing comments when I use the pagination function in Comment List on any setting other than "Load All Comments". When it lazy loads or uses a button to display more or the rest of comments, the images in the next comments have blank spaces where the images should be. Is there a way to get the images to appear in these cases? Refreshing can't resolve the pagination issues because it just refreshes the initial page of comments, not the ones that follow that aren't displaying the images.

Thanks again for your help!


ReplyQuote
Astghik
(@astghik)
Support Team Admin
Joined: 2 years ago
Posts: 2631
16/05/2019 11:34 am  

Hi @phinx1,

 Do I need to do something else to get the Facebook icon to show too?

No, there is not any other options, make sure the "Enable Share Button" option is enabled in the Facebook login section and the "Application ID" and "Application Secret" fields are filled correctly

FB social share

One other question, when I paste the URL for an image then post the comment, it shows just a blank area where the graphic should be. After I refresh the page, it is visible. A similar issue happens with existing comments when I use the pagination function in Comment List on any setting other than "Load All Comments".

Could you please leave some example URL to allow us to check it? 


ReplyQuote
Share: