[Closed] wpDiscuz comment form is missing  

Page 1 / 4
  RSS

Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2951
10/02/2015 5:46 pm  

Hi,

If wpDiscuz comment form is missing on your website, please follow to this instruction.

Tip 1

Navigate to Dashboard > Comments > Forms, edit the Default Form make sure it's enabled for all post types, save it then do Ctrl+F5 on front-end.

wpDiscuz custom post type settings

Tip 2

Some themes don’t use <?php comments_template() ?> WordPress template function, thus wpDiscuz can’t be loaded. You should ask theme support to make sure they use this function in comment section. More information here: https://codex.wordpress.org/Function_Reference/comments_template

Tip 3

Checks the WordPress post "Allow Comments" option and hides the comment form if it's unchecked. This option is located on all posts/pages edit page.

1) Make sure the "Discussions" admin-box is allowed using "Screen Options" in "Edit Post" admin page:

wpDiscuz-form-missing

2) Find the "Discussions" admin-box below and make sure "Allow Comments" option is turned on.

wpDiscuz-form-missing-2

That's it. After this you'll see that all ok, wpDiscuz form is still with you 😉

Tip 4

Also, please go to Dashboard > Settings > Discussions and check this option ON, to set all new posts' commenting enabled by default:

wpDiscuz-invisible-comment-form

Tip 5

Make sure you don' use other comment plugins. For example the Jetpack Comments should be disabled

This topic was modified 1 year ago by Tom

cristianneb
(@cristianneb)
New Member
Joined: 4 years ago
Posts: 1
17/12/2015 5:13 am  

Thanks!!!


renpub
(@renpub)
New Member
Joined: 3 years ago
Posts: 1
29/11/2016 6:21 am  

...then navigate to Dashboard > Comments > Forms, edit the default form and set it for all post types you want.

Aha! I didn't have the pages checkbox ticked, all working now, thanks!


Alex
 Alex
(@sanya)
Member Customer
Joined: 4 years ago
Posts: 12
30/11/2016 2:49 pm  

Thx!!


Arik
 Arik
(@glouds)
Member Customer
Joined: 3 years ago
Posts: 1
05/02/2017 2:20 pm  

i don't have: <?php comments_template() ?>

but i do have :<?php comments_template(); ?>

since the last update of wpDiscuz the template only shows the default wordpress comments! 

wpDiscuz was working fine for the last 4 months and i didn't replace the theme

EDIT: I deleted the semicolon ; from the <?php comments_template(); ?> and now it works. I have no idea why. but maybe it will help someone else

 


Bob
 Bob
(@expolab)
Member Customer
Joined: 3 years ago
Posts: 1
08/03/2017 4:05 pm  

solved thank you.  people could not react after 14 days on posts.

One mor thing i installed the captua but stull i get spam in.

Some sugestions?


Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2951
10/03/2017 10:18 am  

One mor thing i installed the captua but stull i get spam in.

Please navigate to Dashboard > Comments > Forms admin page, edit the Default Form and enable it for all post types, even for attachments.


huy
 huy
(@huy)
New Member
Joined: 3 years ago
Posts: 1
17/03/2017 3:47 am  

Dear friends, 

Please help me, when I modify forms in Forms,

before I see have some fields: name, mail, code, .... and I saved, but after I saved, I view again, but now no have any fields....also no have the "Add" button to add field.

 

Please help me, thanks

 


Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2951
18/03/2017 5:38 pm  

Please try again, edit, make sure it's enabled for all post types and save it. Then delete cach and do Ctrl+F5 on front-end.


gooma2
(@gooma2)
New Member
Joined: 2 years ago
Posts: 1
28/05/2017 8:35 am  

Hi,

I'm having same issue and I have done everything that was suggested in this thread but the regular WP comment section remains.

Example post:   https://movietvtechgeeks.com/rip-gregg-allman-influential-southern-rocker-dies-69/

If there are any other suggestion, they would be greatly appreciated.


Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2951
28/05/2017 11:35 am  

Please try again. Navigate to Comments > Forms admin page, edit the Default Form, make sure it's enabled for all post types, save it, then delete all caches and do Ctrl+F5 on front-end.


pdm
 pdm
(@pdm)
New Member
Joined: 2 years ago
Posts: 3
23/06/2017 10:21 pm  

I am not able to get the Comment form to show. I completed the initial steps listed below...

1) Make sure the "Discussions" admin-box is allowed using "Screen Options" in "Edit Post" admin page:

 

2) Find the "Discussions" admin-box below and make sure "Allow Comments" option is turned on.

 

3) Also, please go to Dashboard > Settings > Discussions and check this option ON, to set all new posts' commenting enabled by default:

I am not techie, just need the comment form to show. 


Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2951
24/06/2017 5:57 pm  

Please navigate to Dashboard > Comments > Forms admin page, edit the Default Form and click on Update button. Then delete all caches and do Ctrl+F5 on front-end.


pdm
 pdm
(@pdm)
New Member
Joined: 2 years ago
Posts: 3
04/07/2017 3:36 am  

Please see attached setting when I went to Dashboard > Comments > Forms admin page. I deleted caches and Ctl+F5 on the front-end. 

 


Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2951
05/07/2017 12:54 am  

I don't see any attachment.


pdm
 pdm
(@pdm)
New Member
Joined: 2 years ago
Posts: 3
11/07/2017 3:26 pm  

Please review the attached and let me know why comments won't show up. 

 

 

Dashboard   Comments   Forms   Default form setting


Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2951
12/07/2017 7:06 pm  

Could you please delete all forms, and create it again? Then delete all caches and check it no  front-end. Also lease deactivate wpDiscuz and make sure the WordPress default comment form works on your theme on the same page. And make sure Jetpack Comments is disabled.


Hoan
 Hoan
(@hoan)
New Member
Joined: 2 years ago
Posts: 1
17/07/2017 2:59 pm  
Posted by: Tom

Could you please delete all forms, and create it again? Then delete all caches and check it no  front-end. Also lease deactivate wpDiscuz and make sure the WordPress default comment form works on your theme on the same page. And make sure Jetpack Comments is disabled.

Hey guy,  I found my problem. Wpdiscuz interfered with JetPack Comment, when i deactived the Jetpack plugin then i immediately  showed the wpdiscuz comment Form. But i still and need to use jetpack plugin, so tell me how can i configure the jetpack setting to not interfered with wpdiscuz. 

Thanks


Tom liked
Tom
 Tom
(@tomson)
Support Team Admin
Joined: 4 years ago
Posts: 2951
19/07/2017 12:13 am  

Sure, this is the first you should do when install wpDiscuz. All other comment plugin should be deactivated once you install wpDiscuz.


hascott93
(@hascott93)
New Member
Joined: 2 years ago
Posts: 1
19/08/2017 12:26 am  

Hi!

I have done everything suggested and the comment form is still missing. I am suppose to launch tomorrow, so I am in major need. I am also not computer savvy at all so any help would be great. 


Page 1 / 4
Share:
Green
Default
Pear
Black Emo
{green}:grinning:
{green}:wink:
{green}:face:
{green}:inlove:
{green}:sweaty:
{green}:surprised:
{green}:lovekiss:
{green}:laugh:
{green}:formalsmile:
{green}:displeased:
{green}:cool:
{green}:resent:
{green}:nerd:
{green}:screaming:
{green}:amazed:
{green}:sad:
{green}:deceitful:
{green}:starryeyes:
{green}:evil:
{green}:shocked:
{green}:tears:
{green}:sulky:
{green}:smile:
{green}:vomited:
{green}:hi:
{green}:afraid:
{green}:crazy:
{green}:rabid:
{green}:fighting:
{green}:nonoise:
{green}:blushed:
{green}:idontknow:
{green}:scared:
{green}:razz:
{green}:kiss:
{green}:eat:
{green}:shutmouth:
{green}:gape:
{green}:suspicious:
{green}:laughingoutloud:
{green}:bruise:
{green}:crying:
{green}:pray:
{green}:serious:
{green}:excitement:
:)
:d
:wink:
:mrgreen:
:neutral:
:twisted:
:arrow:
:shock:
:???:
:cool:
:evil:
:oops:
:razz:
:roll:
:cry:
:eek:
:lol:
:mad:
:sad:
:!:
:?:
:idea:
:hmm:
:beg:
:whew:
:chuckle:
:silly:
:envy:
:shutmouth:
{pear}:happy:
{pear}:smile:
{pear}:laugh:
{pear}:laughingoutloud:
{pear}:crying:
{pear}:exhausted:
{pear}:nerd:
{pear}:surprised:
{pear}:veryhungry:
{pear}:wink:
{blackemo}:laughtertotears:
{blackemo}:gift:
{blackemo}:love:
{blackemo}:inlove:
{blackemo}:shamefaced:
{blackemo}:heart:
{blackemo}:crazy:
{blackemo}:anguished:
{blackemo}:bruise:
{blackemo}:easymoney:
{blackemo}:exhausted:
{blackemo}:vampire:
{blackemo}:shutmouth:
{blackemo}:wink:
{blackemo}:carnival:
{blackemo}:flowers:
{blackemo}:hotdrink:
{blackemo}:party: