Notify on new comments is not working  

  RSS

bprado
Active Member
Joined: 10 months  ago
Posts: 9
31/05/2016 12:12 am  

Hello, on the settings i have "Notify of new replies to this comment" checked by default, and do this test:

  1. From my computer with another browser and another email i made a test comment, the checkbox of "Notify of new replies to this comment" was marked, i made the comments, and the system sent the email to the admin (new comment email)
  2. The admin account (my email) get the notificacion of a new email
  3. The test email (that im using) get the Suscription email confirmation
  4. From the suscription email i confirm making a clic on the email (its strange because i mark the option - Disable subscription confirmation for guests on the settings so i should not get that email)
  5. 5 min later i call one of my blogger to answer the comment from his computer, the blogger have admin access with his own email, he answer from the backoffice (admin area)
  6. The new email that im using for testing DONT GET THE REPLY OR ANSWER OF HIS COMMENT!
  7. Conclusion: The user that is making the comment is not getting the notification about a reply to his comment

Please help


ReplyQuote
bprado
Active Member
Joined: 10 months  ago
Posts: 9
31/05/2016 12:13 am  

You can use this link for testing -->  http://www.bodybuildinglatino.com/articulos/suplementos/hmb-vistazo.html


ReplyQuote
Tom
 Tom
Support Team
Joined: 2 years  ago
Posts: 1379
31/05/2016 11:00 am  

Hi bprado,

Please read this support topic. Go through all points listed there:

http://gvectors.com/forum/how-to-and-troubleshooting/comment-subscription-and-notification-dont-work/

wpDiscuz Documentation


ReplyQuote
bprado
Active Member
Joined: 10 months  ago
Posts: 9
31/05/2016 6:12 pm  

thk, Tom after several tests, its seem its working, but i have a final question:

The user have to confirm the suscription? Can i avoid that and suscribe the user without that confirmation email?


ReplyQuote
Tom
 Tom
Support Team
Joined: 2 years  ago
Posts: 1379
01/06/2016 10:33 am  

Yes, you can. Please navigate to wpDiscuz Settings > Subscriptions Tab and disable Email confirmation for registered users.

wpDiscuz Documentation


ReplyQuote
bprado
Active Member
Joined: 10 months  ago
Posts: 9
01/06/2016 6:30 pm  

Excelent, so if i Disable subscription confirmation for guests, the guest dont need to confirm on the email to get the response of a reply on his comment?


ReplyQuote
Tom
 Tom
Support Team
Joined: 2 years  ago
Posts: 1379
01/06/2016 7:46 pm  

Yes, correct.

wpDiscuz Documentation


ReplyQuote
bprado
Active Member
Joined: 10 months  ago
Posts: 9
02/06/2016 4:00 pm  

Tom, with this options checked, its supposed that on the table _wc_comments_subscription the confirm field should be always "1" ?

 


ReplyQuote
bprado
Active Member
Joined: 10 months  ago
Posts: 9
07/06/2016 12:17 am  
Posted by: bprado

  Tom, with this options checked, its supposed that on the table _wc_comments_subscription the confirm field should be always "1" ?

Hello, still waiting for the answer of this comment, today i make another test, and on the table the setting was on "0" and the user dont get the answer of the comment! Please waiting for your feedback


ReplyQuote
bprado
Active Member
Joined: 10 months  ago
Posts: 9
07/06/2016 2:17 am  

I attach a screenshot of my current settings on the Suscription Tabs and the Table that im looking on the tests


ReplyQuote
Tom
 Tom
Support Team
Joined: 2 years  ago
Posts: 1379
07/06/2016 11:37 am  

Hi bprado,

Guests should have at lease one confirmed subscription to continue subscribe other comments and posts without subscription confirmation.

wpDiscuz Documentation


ReplyQuote
Scott
Active Member
Joined: 2 months  ago
Posts: 9
20/03/2017 5:44 pm  
Posted by: Tom

 

Hi bprado,

Guests should have at lease one confirmed subscription to continue subscribe other comments and posts without subscription confirmation.

   

Tom, this makes no sense to me. You have an option to disable conformation for guests, but yet you are saying they have to confirm at least one email notification? Why?

This is killing my interaction with my guest commentators. I just added this plugin to my site yesterday. 13 comments by new guests but only 1 person actually confirmed the email. That means 12 people are not getting our replies and thusly our site will be hurt when it comes to overall response and traffic.

Can we not have a way to set their confirmation without clicking something in an email?


ReplyQuote
Scott
Active Member
Joined: 2 months  ago
Posts: 9
22/03/2017 8:45 pm  

Hi Tom,

Anything on this question? Thanks


ReplyQuote
Tom
 Tom
Support Team
Joined: 2 years  ago
Posts: 1379
22/03/2017 8:50 pm  

Tom, this makes no sense to me. You have an option to disable conformation for guests, but yet you are saying they have to confirm at least one email notification? Why?

For secure reasons. We can't allow spammers use other people emails and subscribe. This is the most insecure thing you're asking for. If we allow this, in a few days wpDiscuz will be the most spamming comment system of the world.

wpDiscuz Documentation


ReplyQuote
Scott
Active Member
Joined: 2 months  ago
Posts: 9
22/03/2017 9:41 pm  
Posted by: Tom

 

Tom, this makes no sense to me. You have an option to disable conformation for guests, but yet you are saying they have to confirm at least one email notification? Why?

For secure reasons. We can't allow spammers use other people emails and subscribe. This is the most insecure thing you're asking for. If we allow this, in a few days wpDiscuz will be the most spamming comment system of the world.

   

Ok and thanks for the reply. I guess it is confusing to me since other commenting systems I use or have used never required this nor has there been any issues with spam registrations with other people's emails. For example, I switched from IntenseDebate and they did not require an email confirmation. Also as a tip, maybe a change of wording on your settings for Disable subscription confirmation for guests  as it is misleading to the admin. Maybe add "after initial confirmation"

Thanks again.


ReplyQuote
  
Working

Please Login or Register